Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my laptop from 11.04 too 11.10 and since then the CIFS mounts are not working.

Before the upgrade it would allow mounts on host names, in 11.10 it's only IP addresses (not much of an issue), however all the shares I mount are as read-only despite the fstab file declaring the options rw and auto. I have chowned the mount point to be nogroup.nouser and it still wont work, here is an extract from my fstab:

//192.168.1.1/stories /home/paul/Documents/Stories cifs rw,user,exec,auto,username=<user>,password=<password> 0 0
share|improve this question
add comment

3 Answers 3

Try with this one. It worked for me:

//192.168.1.1/stories /home/paul/Documents/Stories cifs iocharset=utf8,file_mode=0777,dir_mode=0777,username=,password= 0 0
share|improve this answer
add comment

Try mounting share with noperm option, e.g. your /etc/fstab line should be:

//192.168.1.1/stories /home/paul/Documents/Stories cifs rw,user,exec,auto,**noperm**,username=,password= 0 0

It is useful when client and host uids/gids differs (see 'man smbmount')

share|improve this answer
add comment

You can use ShareScanner which is almost similar to netscan of windows. It supports nautilus, dolphin and konqueror.You can mount network shares with a mere click. You can download it from:

http://sharescanner.net84.net

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.