Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am dual booting Ubuntu 11.10 and Windows 7 so I created a partition where I can store all my documents and open them through both systems. Everything seemed like it worked out well, I found out how to change the default locations of Documents, Videos etc. but whenever I restart my laptop, they reset. This is what my user-dirs.dirs looks like after I've edited it and it works well with all shortcuts and save locations working correctly:


and after a restart, this is what happens to the file:


Is there any way to make permanent changes to this file?

share|improve this question

2 Answers 2

Most likely it removes those entries because the directories do not exist at the moment when you log in. So I'm guessing /media/storage isn't mounted at that point.

share|improve this answer
That's very likely to be true, is there a way to mount the drive on login or on startup? –  Zach Feb 25 '12 at 12:51
Yes. This might help help.ubuntu.com/community/AutomaticallyMountPartitions –  geirha Feb 25 '12 at 13:06
Thank you, I will look into this and see if I can get it to work. –  Zach Feb 25 '12 at 16:30
I got it to mount on start up but it did not help, it still resets unfortunately. –  Zach Feb 25 '12 at 18:27
@Zach which approach did you use? running udisks via Startup Applications? If so, it's possible it is being run after /etc/xdg/autostart/user-dirs-update-gtk.desktop. I'm not sure how to specify the order of those. It used to be possible from Startup Applications, but that has been removed in newer gnome versions. If you go with an /etc/fstab entry instead, it should work though. –  geirha Feb 25 '12 at 19:28

Did you try to use symbolic links? So the media don't have to be mounted.

share|improve this answer
I have not tried this, would this be easier than mounting it at startup? If so, could you instruct me on how to do it? Thanks! –  Zach Feb 25 '12 at 16:29
Got it running perfectly, used this: howtogeek.com/howto/16226/… –  Zach Feb 25 '12 at 18:37
Seems like it has started to not work again..strange. –  Zach Feb 25 '12 at 21:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.