Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

See attached image. On my dual screen display I have a Unity Launcher on the left hand screen and also on the right hand screen. Both work perfectly fine.

I don't want two Unity Launchers. Every time I move my mouse to the right hand side it gets slowed down over the right launcher hampering my productivity.

I have an Nvidia card with the Nvidia driver and I am using TwinView.

Could somebody please tell me how to remove this extra duplicated launcher?

enter image description here

share|improve this question

6 Answers 6

up vote 125 down vote accepted

You can now.

Open up Display preferences, and then you can choose between having the launcher on one display or all of them.

enter image description here

This dialog also allows switching on or off the sticky edges (i.e. the mouse slowdown) between the displays.

share|improve this answer
3  
Note this works only if Unity correctly detects your dual head configuration - which is not currently the case if you use Twinview with the nvidia drivers. –  kynan Jun 29 '12 at 13:59
1  
It does now, starting with 302.x, the binary Nvidia driver propetly supports RandR. –  Cumulus007 Aug 3 '12 at 20:57
    
My config is TwinView, and with that, I had to use nvidia-settings to set the monitor I wanted the taskbar on as the "primary display for X screen" –  Diederik Oct 2 '12 at 9:12
    
I must have ran that app 50 times today tweaking monitor settings and never saw that! Thanks! –  HDave Apr 4 '13 at 2:31

The slowdown is a feature to make it possible to use the launcher when it's set to auto-hide. I think it's a bug that it's used when the launcher is set to always visible. I've reported it on Launchpad.net, where bugs are filed, and you might want to set it to affect you. You can find it here: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/945847

In the meantime, you can configure it yourself by using /apps/compiz-1/plugins/unityshell/screen0/options/overcome_pressure and /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity in gconf-editor

You can also configure these parameters in CCSM (Compiz Config Settings Manager), in the Unity Plugin, Experimental tab

share|improve this answer
    
Your answer is clear and articulate. I tried what you said and at least I don't have that slowdown problem any more. Although you haven't answered the original question often in IT a workaround is just as good as a solution and that's why I am marking this question as answered. Thank you very much for helping! –  Eugene van der Merwe Mar 5 '12 at 22:16
3  
Nice answer. For the record, I have set the following values: /apps/compiz-1/plugins/unityshell/screen0/options/overcom_pressure=1 to make it possible to pass from one screen to another flawlessly and /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity=20 to still make it possible to access the hidden launcher on the left screen. –  ℝaphink Mar 21 '12 at 8:59
2  
This wasn't a solution for me but pointed me to the right place. @Todd Wallentine below shows that the num_launchers option set to 1 will only display the launcher on the primary screen. –  redbmk Nov 16 '12 at 22:37

I just found a setting in gconf-editor that will allow you to set the launcher to just your primary desktop: /apps/compiz-1/plugins/unityshell/screen0/options/num_launchers. If you set it to 1, the Unity launcher will only be displayed on the primary desktop. If you set it to 0, the launcher will be available on all desktops.

In addition to this setting, I also set the the overcome pressure (/apps/compiz-1/plugins/unityshell/screen0/options/overcom_pressure=1) and stop velocity (/apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity=20).

share|improve this answer
    
I noticed this feature is available in ccsm now, under Experimental tab called "Launcher Monitors" in a dropdown. You can choose "All Monitors" or "Primary Desktop" –  Nicholi Dec 12 '12 at 0:38
    
Additional note, the above settings in gconf are only for the full Unity interface. If you are using Unity2d you can find them in dconf under com/canonical/unity-2d/launcher/only-one-launcher –  Nicholi Mar 13 at 4:41

I tried the combined settings from above:

/apps/compiz-1/plugins/unityshell/screen0/options/num_launchers=1
/apps/compiz-1/plugins/unityshell/screen0/options/overcom_pressure=1
/apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity=20

That was mostly successful for me. A launcher appears only on the primary screen, and the mouse moves from one screen to the next without undue hesitation. However, I found that the remaining launcher would not reveal without using the super key. This can be corrected by setting the following:

/apps/compiz-1/plugins/unityshell/screen0/options/reveal_pressure=1

BTW this is with NVidia drivers.

share|improve this answer

Just changing /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity to 1 fixed the issue for me... I didn't necessarily want to remove the second taskbar, just didn't like the pause when going from one screen to the other.

share|improve this answer

I solved using disper. Type in a terminal:

sudo apt-get install disper

After solving the issue with the method proposed by Paŭlo Ebermann or nvidia-settings or whatever works for you, type in a terminal:

disper --export < /path-to-my-file/my-disper-file.metamode

my-file.metamode is as follows:

backend: nvidia
associated displays: DFP-0, DFP-1
metamode: DFP-0: 1366x768 @1366x768 +1920+312, DFP-1: 1920x1080 @1920x1080 +0+0
scaling: stretched, stretched
xinerama info order: DFP-1, DFP-0

The third row takes into account the particular positioning of two screens with different heights. Your case may be simpler. You could try to create the file that fits your configuration (without using other methods + disper --export). The important point is the order of the screens in the second and in the last rows.

You can use the script and making it run at startup:

#!/bin/sh
#Auto switch single/extend display with disper on Multiple Monitor.
lines=$(disper -l | wc -l)
display_count=$((lines / 2))
if [ $display_count -eq "1" ]; then
   disper -s
else
   disper --import < /path-to-my-file/my-disper-file.metamode
fi

It worked with my nvidia graphics card (both precise and quantal).

Hope it helps.

share|improve this answer

protected by Community Oct 26 '12 at 10:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.