Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded Eclipse from Eclipse page and extracted it in Downloads directory. When I run Eclipse as normal user then application behaves strange:

$ ./eclipse
Gtk-Message: Failed to load module "canberra-gtk-module"

Some symptoms:

  • Eclipse can't resolve symbols in source code and marks them as invalid
  • GUI looks like in other KDE applications
  • when I quit program, then there is some error about write protection

Error message:

Problems occurred while trying to save the state of the workbench.
Could not write metadata for '/ab'.
/home/user/workspace/.metadata/.plugins/org.eclipse.core.resources/.projects/ab/.markers (Permission denied)

I encountered some other problems like write problems during update.

However when I run Eclipse as super user:

$ sudo ./eclipse

then everything works as it should and GUI looks different (GTK is loaded or what? I don't know).

I tried to give 777 permission to all files in Eclipse directory but it didn't work. And I didn't install Eclipse anywhere, just downloaded and extracted. I tried also to download Eclipse with apt-get but there was the same problem. How to make Eclipse work correct?

I use Kubuntu 11.10.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Possibly the permissions on your workspace are messed up? Usually that's in ~/workspaces, so if you do a chown -R on that tree, it might help.

share|improve this answer
add comment

I think that you should use gksudo (kdesudo on Kubuntu) to run graphical applications.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.