Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

VLC 2.0.1 is behaving oddly, and since it does not appear to offer any increase in performance over 1.1.12 I would like to downgrade to the latter. However, this appears to be non-trivial.

After running these commands:

sudo apt-get remove --purge vlc
sudo add-apt-repository -r ppa:videolan/stable-daily
sudo apt-get update 

VLC 2.0.1 should be gone, as should the ppa from which I got it. However, it is still not possible to install VLC 1.1.12. When I try to, I get an error message about broken dependencies:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 1.1.12-2~oneiric1) but 2.0.0+git20120222+r100-0~r29~oneiric1 is to be installed
       Depends: libvlccore4 (>= 1.1.0) but it is not going to be installed
       Recommends: vlc-plugin-notify (= 1.1.12-2~oneiric1) but it is not going to be installed
       Recommends: vlc-plugin-pulse (= 1.1.12-2~oneiric1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

How can I reinstall VLC 1.1.12?

share|improve this question
    
Instead of removing the PPA, try purging the PPA. That would automatically downgrade VLC. –  jokerdino Feb 24 '12 at 16:35
    
Same issue as this question: askubuntu.com/questions/106692/devede-wont-open-in-ubuntu-11-10/… –  Luis Alvarado Feb 24 '12 at 16:46
1  
The problem is that you've removed the main package but you still have vlc-nox libvlccore4 vlc-plugin-notify vlc-plugin-pulse comming from the vlc2.0 ppa installed from your system. If you want to go that way, run sudo apt-get remove --purge vlc vlc-nox libvlccore4 vlc-plugin-notify vlc-plugin-pulse The solution given by Jorge is easier and will take care of everything. –  Mathieu Comandon Feb 24 '12 at 17:11
add comment

1 Answer 1

up vote 3 down vote accepted

Re-add the ppa that you downloaded 2.0.1 from, and then use ppa-purge. More info can be found here:

share|improve this answer
    
ppa-purge removed a whole bunch of seemingly unrelated packages, but was not able to fix the problem. Mathieu Comandon's suggestion to --purge everything however did fix the problem. Or it might have been a combination of the two. In any case, I've got 1.1.12 installed, and it behaves exactly like 2.0.1 did. facepalm –  bessman Feb 24 '12 at 18:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.