Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use ubuntu 11.10. I recently installed gnome shell. The problem I'm facing is that i'm not able to restart or shutdown from ubuntu. I clicked on restart or shutdown button and nothing happens. Just nothing.

I even try to login from my unity shell and still the problem persists. Even more funny, when I boot into linux, and seeing the login screen, Still even after clicking on shutdown, I won't happen.

What mistake have I performed?

But I'm able to perform reboot with the command "sudo reboot".

Any assistance please.

Thanks in advance.

share|improve this question
    
Have you same problem in unity too? –  Tachyons Feb 24 '12 at 16:14
add comment

4 Answers 4

I found that someone had logged in to the guest account. Unity won't shut down when someone else is logged and it doesn't give you any indication that someone else is logged in. Logging the other user out solved my problem.

share|improve this answer
    
I just figured that out myself. It is very annoying. –  peck Apr 11 '12 at 3:52
add comment

I used to have the same problem. Try running this on a terminal:

sudo poweroff

If you do that each time the issue occurs, it should start working.

Also see if there is a .Xauthority file in your home folder owned by root. If there is, log in a text console (Alt+Ctrl+F1) at the login screen, and then run

sudo rm ~/.Xauthority

share|improve this answer
add comment

I agree with Misery on this one. Create a file in the directory (Create it if it doesn't exist.) /home/(your-username-here)/bin called power.sh

Insert the following code into the file:

#!/bin/bash
# Program to manage the computer for shutdown/reboot.
# Created by Dominic Rodriguez (shymega).
# Declare Variables:
shutdown="shutdown"
reboot="reboot"
if [ "$1" = "$shutdown" ];
then
echo "Shutting down computer."
sudo shutdown -h now
elif [ "$1" = "$reboot" ];
then
echo "Rebooting Computer."
sudo shutdown -r now
else
echo "No Arguments were specified."
echo "Usage: power.sh shutdown/reboot"
echo "Thank you for using power.sh"
fi
exit

After inserting that code, right click on the file, and select Permissions. You should find a option saying 'Make this file executable.'. Tick that option. Then close the window.

Now whenever you want to shutdown, open the terminal and type 'power.sh shutdown or reboot.' (Without the quotation marks)

Good Luck!

-- sm

share|improve this answer
add comment

Such post showed up here few times. It might be a bug. Simple workaround is to create an activator running reboot or shutdown script.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.