Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I unknowingly tried to change my 480 GB NTFS partition to ext4 from GParted. It did not warn me about any formatting, so i thought the data would be preserved. However, It encountered an error and now my partition is missing from nautilus. Gparted and disc utility show it as unknown unformatted partition.

I want to recover my data now. How can it be done?

share|improve this question
    
sleuthkit to recover files on the whole...or scalpel or similar to recover individual files on a partition if you just want a fire and forget. –  hbdgaf Feb 24 '12 at 9:04
    
Can you use fdisk to change the partition type back to ntfs? –  user8290 Feb 24 '12 at 11:19
    
I was unable to change it back to ntfs, no probs, had recovered the data by booting from a live cd.. :) copied it, and got rid of that drive.. :) thanks for your replies. –  Mahesh Feb 26 '12 at 7:22
    
Don't forget to close/answer your question :) –  Huckle Mar 17 '12 at 2:41
    
@Huckle Sorry, I checked only for closing it. I only found Delete option. And i didn't consider the status being left unanswered.. –  Mahesh Mar 18 '12 at 8:33
add comment

1 Answer

up vote 0 down vote accepted

Live booting worked for me. Thanks for the response.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.