Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently tried to install Ubuntu on my new Lenovo V570, planning to dual boot 11.10 with Windows 7. I realized after installing that it would boot straight into Windows, so I looked up the issue. I read something about UEFI, and found a page suggesting that I wipe the drive with GParted, installing a msdos partition table, and then install Ubuntu. (I tried linux mint first, because that's what I had on my flash drive at the moment.) I attempted this, and now I'm left with a computer that won't boot anything from the hard drive. If I install Ubuntu or Linux Mint 12 using either MSDOS or GPT, it simply skips the hard drive. My BIOS has no option to disable EFI, and I'll admit I know shamefully little about EFI or different types of partition tables. I'd like to know what I have to do to make my computer boot again.

share|improve this question

3 Answers 3

I'm using a Lenovo V570 also, and Ubuntu 11.10 (the 12.04 alpha also) and LinuxMint 12 (All 64bit) both set up EFI partitions for themselves automatically (In a 20mb FAT partition). Currently my hard drive (which is the one that came with the laptop is set up as follows - 20MB FAT (EFI system partition) - 30GB EXT4 (Root Partition) - 604GB EXT4 (Home Partition) - 6.4GB Swap Space (which is probably really excessive). All of this is under a GUID partition table, which wikipedia just told me is part of the EFI standard. My guess would be to boot into the live environment and with the disk utility change the partition table from msdos to GUID. I'm by no means an absolute authority in this matter but I hope this helps.

share|improve this answer

I'm answering my own question:

It turns out I didn't have UEFI after all, but for some reason my Lenovo was incapable of booting with GRUB. I couldn't figure this out myself, but I found a workaround. I installed windows 7, and used the Wubi installer to install Ubuntu 11.10, then set up the partitions I had set aside already in fstab. It's not exactly what I wanted, but the result is exactly the same. I also get the added bonus of editing the Windows bootloader via EasyBCD, instead of having to mess with grub. For simplicity and stability, this approach could be recommended to anybody who doesn't feel like or can't manually mess around with their system's boot loader.

share|improve this answer

I have a Lenovo V570. Installing Mint 12 or Debian 6 worked fine. Installing Ubuntu 11.10 or 12.04 Beta 2 seemed to work fine -- the graphical installer worked fine -- but upon reboot, the OS would not come up.

Googling around got me to this solution :

Boot liveCD. Run graphical installer. Then before rebooting, fire up a terminal.

sudo apt-get install efibootmgr
sudo modprobe efivars
sudo efibootmgr

The first line installs efibootmgr, the second line adds efi support to the kernel running in the livecd environment, third line shows all the options for booting in your machine's bios/efi boot screen. When I did this, I saw that Ubuntu was listed, as option 9, and option 9 was not part of the options marked as bootable.

So to change the boot order I first researched using man efibootmgr and found :

CHANGING THE BOOT ORDER FOR THE NEXT BOOT ONLY

Assuming the configuration in Example #1, efibootmgr -n 4 could be called to specify that the Linux entry be taken on next boot.

CHANGING THE BOOT ORDER

Assuming the configuration in Example #1, efibootmgr -o 3,4 could be called to specify PXE boot first, then Linux boot.

So in my case, with Ubuntu listed as option 9, I did :

sudo efibootmgr -o 9,andthensomeotheroptionslikemycddrive

I then rebooted, removed the livecd when prompted, and was greeted by a working Ubuntu installation.

What I suspect happened : Linux Mint 12 and Debian 6 installers both looked at the machine's EFI/GPT partition table and said, "Meh. Whatever." and just reformatted it to an msdos/mbr partition table, installed their system, and threw grub2 on the mbr. Old school style, but it works a treat. Ubuntu 11.10 and 12.04 Beta 2 installers looked at the machine, tried to set up for EFI/GPT booting, and successfully did so, except for reordering the BIOS/EFI boot order and putting Ubuntu first. Instead, the installers just left the BIOS/EFI boot order alone, and so Ubuntu as a boot option just, well, wasn't--as far as the machine was concerned.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.