Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In rfkill list my wireless lan shows as "hard blocked". How can I unblock it?

share|improve this question

closed as off topic by James May 23 '12 at 17:15

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
I don't own one, so I can't tell you where the switch or what the key combination is. You don't list the laptop model only the wireless module, so I can't google for a diagram. Hard-block indicates a switch, bios disable, or key combination to disable the hardware. – RobotHumans Feb 24 '12 at 6:04
1  
@aking1012 Thanks for looking. I tried all the options available in various forums, but it turned out to be a very peculiar issue. There indeed is a Fn + F8 key combo for this but it wouldn't work. I opened the terminal for checking something else and pressed the Fn + F8 keys and surprise! The Wireless LAN turned on! So, the issue here is The Fn key combination works when we are in the terminal mode and does not work in other (GUI) windows. I use CCSM - so would it be trapping the Fn key press? – Sri Feb 24 '12 at 9:33
    
The laptop is CR400. – Sri Feb 24 '12 at 9:34
    
It's possible that it's getting trapped by any number of things. At least you have a semi-workable solution. File a bug report against the driver. They'll say it's not their problem and suggest a package to file a bug report against. Keep following the blame game until you get results – RobotHumans Feb 24 '12 at 11:21
up vote 2 down vote accepted

OP Posted:

I tried all the options available in various forums, but it turned out to be a very peculiar issue. There indeed is a Fn + F8 key combo for this but it wouldn't work. I opened the terminal for checking something else and pressed the Fn + F8 keys and surprise! The Wireless LAN turned on! So, the issue here is The Fn key combination works when we are in the terminal mode and does not work in other (GUI) windows.

share|improve this answer
    
Fn + F8 key combo also works to activate the WiFi in 12.04 Xubuntu installed on a HP Compaq tc4200, forget the dedicated wifi unblock button on the side of the laptop – Jose Elera Jan 8 '13 at 19:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.