Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying out ubuntu 12.04 and I noticed that a process called Geoip is connecting to the internet at every boot/login. Why is this necessary? How do I disable this behavior?

share|improve this question
    
I'm posting this as a comment as I'm not sure it's an answer, but is it possible to identify the process and then rename its file(s) to stop it loading? (I just tried this with geoclue-master but it broke my indicator-datetime. Annoying.) –  dunderhead Apr 13 '12 at 8:02

2 Answers 2

I stumbled upon a way to disable this connection (this may only apply to 12.10).

  • Open your dconf editor: $ dconf-edditor
  • Navigate to the com/ubuntu/geoip option
  • Set the value of geoip-url to nothing "".

Done. Happy days, no more geoip connections.

Disclaimer: I don't know if there any negative effects of disabling geoip provider connections in the way described above, because I still don't fully understand why this connection must call home.

See the SO question I have permanent connections to Canonical servers, what are they for? for more details.

share|improve this answer

There is currently no way to disable the geoip check. It is currently used to determine if your timezone has changed. In the future we should really add an option to disable it or at least reduce the dependency on the geoclue-ubuntu-geoip package to a recommends so users can just un-install that. I just tested that and it breaks indicator-datetime, I will make sure that gets addressed for 12.10.

share|improve this answer
    
Just for the record, since I'm using autovpn, this feature is completely useless. –  iElectric Jun 24 '12 at 12:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.