Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just did a fresh install of 11.10 Desktop 64-bit. When trying to add some new application to the launcher weird things are happening.

The problem in the following: I tried opening a Terminal from the Dash. When the terminal icon appeared in the Launcher, I chose Keep in Launcher. Then I close the terminal. As expected the Terminal icon is still in the Launcher. So far so good. Now, if I open a Terminal using the Launcher, a second Terminal icon appears, and stays after closing. If I open Terminal again, a third will appear and so on.

Screenshot:

The same happens with other applications that were not initially in the Launcher, but not with the original ones, like Ubuntu One.

Update: The problem can be solved by logging out and in again every time I add a new icon to the launcher. It's definitely a bug. I shall report it.

Update 2: Bug reported

share|improve this question

closed as off topic by Ringtail, jrg Apr 7 '12 at 13:27

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I experienced this problem on a 32-bit system (i386), too. Does it appear after a reboot (or after a session restart)? –  Jakob Feb 23 '12 at 10:16
    
Yeah, I've got this problem as well sometimes (about once a month and only with Firefox for now). Seems to be something Ubuntu borrowed from Windows 7, where I first experienced this issue (at school) :p I'd report it as a bug if I were you, because then there's a good chance it will get fixed before Ubuntu 12.04 gets released. –  RobinJ Feb 23 '12 at 10:46
    
I could successfully keep a program in the launcher after logging out and in again. However, in the new session the problem persists if I add new programs to the launcher. So I need to log out every time I keep a program in the launcher. –  Will V Feb 23 '12 at 22:41
    
If you temporarily move all the files from ~/.local/share/applications to another folder (e.g.~/backup) logout and login, does the problem reoccur? –  fossfreedom Feb 23 '12 at 23:24
    
@fossfreedom No, it does not help. There was a single file in ~/.local/share/applications: mimeapps.list. –  Will V Feb 23 '12 at 23:58
show 3 more comments

Browse other questions tagged or ask your own question.