Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a real Ubuntu newbie but at the school where I work I managed to install Ubuntu then install pptpd.

I was feeling very pleased with myself when last evening from home with my Apple iPhone through my wi-fi, I was able to connect and access all resources on the network. Same thing with my Mac.

However, when I turned off the wi-fi on my phone and tried to access through 3G it didn't work. When I had a "Proper" VPN server installed at school it worked fine so I can't see that it's my network provider turning off VPN...

Anyone any ideas?

BTW - the commands that seemed to make the difference on connecting to all resources seems to be the following:

sudo iptables -t nat -A POSTROUTING -0 eth0 -j MASQUERADE sudo sysctl net.ipv4.ip_forward=1

share|improve this question

1 Answer 1

Maybe the problem is the configuration of your home router. Did you activate the port forwarding from your internet router to your ubuntu server? Additionally your router must have the ability to forward the GRE protocol too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.