Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using this how-to How do I set Windows to boot as the default in the boot loader? I was able to get as far as here, however when I try to type in gksu gedit /etc/default/grub I am given 4 lines repeating the same message:

(gksu:2022): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap"

Please help

share|improve this question
add comment

3 Answers 3

I have no idea on how to work with GRUB in this situation, but why not use BCD (Windows Boot Loader)?? It's much easier to use, and there's very few command-line commands needed to install and/or keep up with what's installed. This works for Vista Home premium (All Vista versions except for Starter) and Windows 7 (minus starter). Boot using the Windows rescue disc, or the installation media. Either way, it doesn't matter. Go to the options that include a command prompt, and a few other of the rescue tools. At the prompt, type 'Bootrec.exe /FixMbr', and enter. Reboot, and you have the ability to boot Windows. This option requires setup from within the Windows system, therefore you shouldn't see Linux (and any other OS's you have) on the listing right away. Boot into Windows, install 'EasyBCD', and add an entry for any other OS you have. All done :-) EasyBCD is a million times easier than working with GRUB, and it's much more convenient to use. Plus, if you have Windows installed, why not use it anyway?? It's absolutely no faster, or slower, than Linux.

share|improve this answer
    
If the command doesn't work right off, Try either 'bootrec.exe /FixMbr', 'Bootrec.exe /fixmbr, or something of the sort ((you get the idea)) –  Robert Sederholm Mar 10 '12 at 17:49
add comment

It sounds like all you need is Grub Customizer. In the terminal, enter each of these commands:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

Then open the Dash, find the program, and run it. It will allow you to change the order in Grub, which is all you need to do since the first item boots by default. Choose the Preferences icon, and a window will open: the first setting listed is "default entry"; use the dropdown next to it to choose your Windows boot, close the window and Grub Customizer, reboot and Windows should be listed first and will therefore be the default.

enter image description here

share|improve this answer
add comment

To get rid of the warning you must install the gtk2-engines-pixbuf package.

If that doesn't fix it you can use, for example, nano, is not as easy as gedit but you should be able to make the modifications the tutorial states.

Just type:

sudo nano /etc/default/grub

navigate with the arrows, save with [Ctrl] + O and exit with [Ctrl] + X

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.