Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm not sure how to get the OEM install mode working with my Ubuntu remaster. I'm using Remastersys to make the remastered Ubuntu 10.04 distro and I don't know how to make sure OEMs can use it. I have tried running sudo oem-config-prepare after installing the remaster (with oem-config, oem-config-gtk, oem-config-remaster and oem-config-debconf installed from Synaptic) in a new account called "oem" with the password also "oem". It tells me that I have to restart to show the system setup. So I did that, but it would not start into it. I pressed the Escape key at Plymouth to view the bootup in verbose mode and it told me this:

Traceback (most recent call last):
File "/usr/bin/ubiquity-dm", line 476, in <module>
  dm = DM(vt, display, username)
File "/usr/bin/ubiquity-dm", line 78, in __init__
  self.uid, self.gid = pwd.getpwnam(self.username)[2:4]
KeyError: 'getpwnam(): name not found: live'

multiple times and that I could make a new account from the boot prompt. I attempted to do this but it was choppy and my key presses didn't appear to do anything until I pressed Enter when it displayed only some of the key presses so setting up an account from the boot prompt was futile. I have also tried setting the live username to "oem" but the regular 7-step, non-oem installer shows up when I run Ubiquity. I really need this to work as soon as possible!

Thanks in advance!

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 16:30

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

That error reported looks like It's not created the user 'live' and that user has no password. Did you configure your install scripts correctly? Or did you edit the usernames correctly?

share|improve this answer

Old thread, buy I have the same question. This has been answered here: http://ubuntuforums.org/showpost.php?p=9893658&postcount=2, apparently all you have to do is specify the user as oem in Remastersys.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.