Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok. I installed Ubuntu 11.10 on my computer and everything works fine. I installed Compiz config Settings, and it shows that the Ubuntu Unity Plugin is unchecked. I researched and found out that I am running Unity 2D (even when i log in under "ubuntu"). When I check the Ubuntu Unity Plugin in Compiz, it opens Unity 3d (i assume). But the Unity 2d launcher is still running. They are on top of each other and the icons in the 3D launcher are not visible, however when i run my cursor over them, the bubbles show up (firefox, dash home, etc..) How can I disable Unity 2D and enable just the 3D? And how can i make the icons visible?

share|improve this question
    
Have you tried a reboot since you installed compiz? If you login with Ubuntu selected as your shell that is actually Unity 3D. Sounds like you have a process of 2D hanging out there still. –  Scott Stookey Feb 22 '12 at 23:00

2 Answers 2

Installing Compiz Config Settings does not assure you can run Unity 3D. Open a Terminal and type /usr/lib/nux/unity_support_test -p; the output should tell if you can either run or not Unity 3D. This is the output I get:

OpenGL vendor string:   X.Org
OpenGL renderer string: Gallium 0.4 on AMD RS780
OpenGL version string:  2.1 Mesa 7.11

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes
share|improve this answer
1  
Ahhhhh.. Thank you, I ran the unity support test, and my graphics card is backlisted. So therein lies my problem. However, today I installed an ATI Radeon 9800 Pro graphics card and my desktop is whack.. I can't see my top panel and compiz is not running. I opened "Additional Drivers" and it said there is no proprietary drivers being used. And it doesn't give me the option of activating the FGLRX driver, which I think I need. So my new question is this: "what driver can I use that will give me 3D support for both unity and compiz" –  Matthew Feb 24 '12 at 22:08

It would help to know the video card you have. If it supports the OpenGL minimum requirements for unity 3D then it will work. If not then even if you change anything in compiz you will not have Unity 3D or any of the effects associated with it.

It also helps if your card has a proprietary driver or not. In the cases of Nvidia and Ati cards you have an option to install the proprietary drivers (Via the "Additional Drivers" app). But in both cases, the open source drivers that come by default for both of them already work with Unity 3D.

In the cases for Intel cards, very old models will have it difficult to work with Unity 3D so they will "fallback" to Unity 2D even if you select Unity 3D. This is a way Ubuntu handles the lack of support for the 3D version of Unity in the PC.

To install the latest Proprietary or Open source drivers for Ati/Nvidia You can install the PPA here: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

Also look here for more info: How to install ATI Radeon 6770 drivers on 10.04?

share|improve this answer
1  
Today I installed an ATI Radeon 9800 Pro graphics card, and I think ubuntu is using a generic driver. I can't figure out how to install the proprietary driver. I opened "Additional Drivers" and it doesn't give me any options whatsoever. I know the card is capable of 3d Acceleration, but I don't know which driver to use.. Any help would be appreciated –  Matthew Feb 24 '12 at 22:11
1  
Updated to include 2 ways of installing the drivers. –  Luis Alvarado Feb 24 '12 at 23:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.