Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install KDE but I can't!! When I mark kde-full in synaptic to install it returns this error

kde-full:
 Depends: kde-plasma-desktop but it is not going to be installed
  Depends: kde-plasma-netbook but it is not going to be installed
  Depends: kdeartwork but it is not going to be installed
  Depends: kdeedu but it is not going to be installed
  Depends: kdepim but it is not going to be installed
  Depends: kdeplasma-addons but it is not going to be installed
  Recommends: kde-standard but it is not going to be installed
  Recommends: kdesdk but it is not going to be installed
  Recommends: kdewebdev but it is not going to be installed

I have these packages in synaptic but I think they are newer version of them! Is it the point? What should I do? How do I get lower version of packages? Or how to get index of lower version of packages?

share|improve this question
    
i can't understand what you say !! pleas write english –  hamed Feb 22 '12 at 21:38
1  
sorry sir for this mistake –  Mahmoud20070 Feb 22 '12 at 21:44
add comment

3 Answers 3

up vote 3 down vote accepted

Use the following command in terminal:

sudo apt-get update

sudo apt-get upgrade

and then choose one of these:

  1. Only KDE core, like themes, aero, toolbar and other KDE viewes this recommended (247 Mb):

    sudo apt-get install kde-standard -y 
    

    OR

  2. The following will install the full Kubuntu system. Of course, you don't need this, because this is a full operating system (1 Gb):

    sudo apt-get install kubuntu-full -y
    
share|improve this answer
    
he's not using on-line repositories... –  sorush-r Feb 22 '12 at 21:38
    
if you mean that problem in repositories he can update it and fix from ubuntu cd but i don't remember this command now –  Mahmoud20070 Feb 22 '12 at 22:05
    
afaik it's not possible to fetch KDE packages from Ubuntu CD, they're not there! Did you mean the DVD of repositories? –  sorush-r Feb 22 '12 at 22:12
1  
no i mean to fix default repositories and remove other repositories if found and try again to download and install it Generally I think that i bring solution in other answer in link –  Mahmoud20070 Feb 22 '12 at 22:42
    
tnx, but i changed my local repository to online repository and fell in this problem –  hamed Feb 23 '12 at 8:09
add comment

I Think you're using a local repository and your maintainer could not managed to satisfy unmet dependency prevention in whole repository. This occurs usually when maintainer tries to add some new stuff without considering dependencies... So, whole dependency system become invalid.

share|improve this answer
add comment

see this man this person have same problem and in last comment he wrote the solution i tried to understand it but i can't frankly so i will put the link you try

http://ubuntuforums.org/showthread.php?t=1812528

and forget to check repositories in software sources window for any strange repository and uncheck it if you see that

share|improve this answer
1  
thanks , my problem solved with upgrading repositories with this command sudo apt-get upgrade –  hamed Feb 23 '12 at 8:07
    
thanks man for write your solution to help other a lot of member here didn't do that thank you man –  Mahmoud20070 Feb 23 '12 at 10:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.