Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing the latest version of VLC player I found that DeVeDe had been removed & would not re-install. After following some advice on this site I managed to purge VLC completely & re-install DeVeDe but now when I try to launch it I get a message saying the program can't find mencoder & will not work without it. I have uninstalled & re-installed mencoder several times in synaptic to no avail, DeVeDe still says it can't find mencoder. Any advice?

share|improve this question
    
what is the output from apt-cache policy mencoder and also did you remove the ppa that you used to install vlc ? –  duffydack Feb 22 '12 at 21:08
    
you can also grab the newest version which uses ffmpeg as default backend (much better imo) from rastersoft.com/programas/devede.html#download_section –  duffydack Feb 22 '12 at 21:42
    
When I put that into Terminal I got this... Installed: 2:1.0~rc4.dfsg1+svn33713-1+medibuntu2 Candidate: 2:1.0~rc4.dfsg1+svn33713-1+medibuntu2 Version table: *** 2:1.0~rc4.dfsg1+svn33713-1+medibuntu2 0 500 packages.medibuntu.org oneiric/non-free i386 Packages 100 /var/lib/dpkg/status 2:1.0~rc4.dfsg1+svn33713-1 0 500 gb.archive.ubuntu.com/ubuntu oneiric/universe i386 Packages Re ppa question, I followed this; sudo apt-get update; sudo-apt-get purge vlc sudo apt-get clean sudo apt-get autoremove sudo apt-get install -f devede Thanx for replying! –  Paul Townshend Feb 23 '12 at 15:46
    
duffydack, what version of mencoder are you using? where did you get it? I've purged, clean, everything and I always get the same thing as Paul. –  Trevor Feb 24 '12 at 2:03
    
mencoder: Installed: 2:1.0~rc4.dfsg1+svn33713-1+medibuntu2 –  duffydack Feb 24 '12 at 22:16
show 1 more comment

2 Answers 2

Take into consideration that the LATEST version of VLC which is the 2.0 right now (Using the PPA for it) has different mplayer, mencoder and other packages than the ones devede, openshot and other programs that use this tools need.

So if you are talking about the latest VLC being VLC 2.0 then you probably just changed several packages (mencoder, mplayer, ffmpeg..) with the ones that come with VLC 2.0. This will create a problem for programs like Pitivi, OpenShot and DeVeDe.

The only fix I know of is to delete VLC 2.0 and the PPA that brought it. After that update the repositories so the reflect the deletion of the VLC 2.0 PPA. Then install VLC again which will in this case reinstall all the packages that were removed or modified by VLC 2.0.

If any of this packages happens to stay just purge it then download it again. In this case you will only have the ones that officially come with Ubuntu so after installing them DeVeDe, OpenShot (in my case when I tested) and Pitivi should all work again.

A normal step to do this would be:

  1. sudo apt-get purge vlc
  2. REMOVE PPA FROM VLC 2.0 via Software Sources
  3. sudo apt-get update
  4. Verify that the VLC that is left is the 1.x version: sudo apt-cache show vlc| grep Version. It should say some version that starts with 1.x.
  5. If the version IS 1.x then: sudo apt-get install vlc if not reboot that PC until she learns how things work around here (Just in case).

This is how I did it to restore all the rest of the programs. If any of them say they are missing X package then just install it. For example if they say they are missing mencoder then sudo apt-get install mencoder. Repeat for any package still missing after installing VLC 1.x

share|improve this answer
    
I think I follow what you say, do you mean for me to get rid of VLC 2.0 (which I have done) & then re-install the older version of VLC? I tried to find the older version but always the links take me to the new version. –  Paul Townshend Feb 24 '12 at 2:21
    
I will update the answer to include the procedure for cleaning the repo off vlc 2.0 and whatever other error it might give you. –  Luis Alvarado Feb 24 '12 at 2:35
add comment

Updated 27-2-12

sudo apt-get autoremove --purge vlc mencoder mplayer mplayer2 vlc devede
sudo rm /etc/apt/sources.list.d/n-muench-vlc-oneiric.list
sudo apt-get update
sudo apt-get autoremove --purge
sudo apt-get install devede

Should be good to go

share|improve this answer
    
Tried that, still get the same message that DeVeDe can't find mencoder. It seems that I need the older version of mencoder but always the new version is downloaded whether via Terminal or synaptic. I've looked on MPlayer website for older versions & there are lots to choose from but I really don't know which one! mplayerhq.hu/MPlayer/releases Thanks again everyone for replying to me. –  Paul Townshend Feb 23 '12 at 22:42
    
Works fine here. Make sure the ppa is GONE and nothing is left over from vlc like vlc-nox. To make sure I guess remove everything installed in my 'answer' even the latest devede, run an apt-get autoremove --purge and apt-get clean and install devede from main repo and it should pull mencoder from medibuntu since you have it enabled. –  duffydack Feb 23 '12 at 23:21
    
Yep, ppa is gone & I removed everything else. I re-installed devede first then mencoder & as mencoder was installing I noticed a brief message "configuring devede" & yet still devede will not launch, same message "cannot find mencoder" I'm convinced I need an older version of it. Thanks again for trying! –  Paul Townshend Feb 24 '12 at 2:18
    
if you removed vlc *completely" and you don't have the ppa (sudo apt-get update after removal) then it will get the mencoder it needs. I tried all of this in a vm and it's working for me :( is mplayer2 installed? if it is, remove it –  duffydack Feb 24 '12 at 11:49
    
When I get rid of everything, VLC, mencoder, mplayer2, devede, & then try to re-install devede I get a message saying "devede: Depends: mencoder but it is not going to be installed" & when I install mencoder separately I'm back to the same scenario i.e. devede cannot find mencoder even though I just installed it! I'm following everything you're telling me but it's not working for me, I am very grateful for the time you've taken to help me though, thanx again. –  Paul Townshend Feb 24 '12 at 20:57
show 3 more comments

protected by jrg Feb 27 '12 at 13:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.