Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to connect my laptop using an USB modem. I have tried the modem on a Windows 7 machine and it works fine, so I regard my trouble is software related. But I use Ubuntu 11.10 on daily basis, so I need to make it work on Ubuntu 11.10.

Before connecting the modem I clear up the messages with:

sudo dmesg -c

Then I connect the modem, wait for a moment and execute dmesg one more time. This is the result:

[91378.255708] usb 3-1: new high speed USB device number 5 using xhci_hcd
[91378.272193] xhci_hcd 0000:03:00.0: WARN: short transfer on control ep
[91378.272318] xhci_hcd 0000:03:00.0: WARN: short transfer on control ep
[91378.272410] xhci_hcd 0000:03:00.0: WARN: short transfer on control ep
[91378.274833] xhci_hcd 0000:03:00.0: WARN: short transfer on control ep
[91378.274953] xhci_hcd 0000:03:00.0: WARN: short transfer on control ep
[91378.412746] xhci_hcd 0000:03:00.0: WARN: short transfer on control ep
[91378.412854] xhci_hcd 0000:03:00.0: WARN: short transfer on control ep
[91379.410604] usb 3-1: usbfs: USBDEVFS_CONTROL failed cmd mtp-probe rqt 128 rq 6 len 1024 ret -110

The modem is actually detected::

$ lsusb | grep -i modem
Bus 003 Device 006: ID 047e:2892 Agere Systems, Inc. (Lucent) Systems Soft Modem

But gnome-ppp won't see it.

Update

Following the comment from Scott, I think I should rephrase my question to this:

have anyone figure out the right switchmode command for the Agere modem 047e:2892?

Any ideas?

Best regards,

Manuel.

share|improve this question
    
It's not an answer, but it's relevant: comments.gmane.org/gmane.linux.linmodem/30106 ... essentially if you want support, buy supported hardware. –  hbdgaf Feb 22 '12 at 19:21
    
how about posting the output of sudo lshw -C network –  Ringtail Feb 22 '12 at 19:33
add comment

1 Answer 1

up vote 1 down vote accepted

More and more USB devices have their MS Windows drivers onboard; when plugged in for the first time they act like a flash storage and start installing the driver from there. After installation (and on every consecutive plugging) the driver switches the mode internally, the storage device vanishes (in most cases), and a new device (like an USB modem) shows up. Modem maker "Option" calls that feature "ZeroCD (TM)" since it eliminates the need for shipping a separate driver carrier.

I would imagine that Ubuntu is detecting your modem as a usb flash drive instead of a modem and that's why gnome-ppp is not detecting it. You need to set the mode manually in order for it to be detected as a modem. I have provided a link to download and explain in further detail on how to go about performing this operatioin.

http://www.draisberghof.de/usb_modeswitch/

share|improve this answer
    
I will read the link and report back later. Thanks, and best regards, Manuel. –  manu Feb 23 '12 at 22:52
    
The link provided, though quite informative, haven't helped me. The basic problem is that I have not been able to find the correct switch command for my modem. Furthermore, no Agere modem is currently supported directly by usb_modemswitch. At least, there are no 047E on my /lib/udev/rules.d/40-usb_modeswitch.rules files. –  manu Feb 25 '12 at 4:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.