Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My problem is that on my system HP/DC7900, I have always the same sound like on my sound card on the internal PC speaker. I check all settings and don't find an option to disable the internal PC speaker.

Is there any solution for this problem?

share|improve this question
add comment

1 Answer 1

You can temporarily disable the internal speaker with this command:

sudo modprobe -r pcspkr

Or to permanently disable it create a new file in /etc/modprobe.d/ called something like blacklist-pcspkr.conf or whatever you'll recognize. Add the following line to that file:

blacklist pcspkr

Of course, that will completely disable the speaker while the OS is running, so things like command line typos that make it beep as feedback won't happen either (BIOS errors will still work as the OS won't have disabled it by that point). If you want it to beep when it normally would on certain errors, but not to play music through it, then that will require some further troubleshooting into your sound settings to see why everything is playing through that output.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.