Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu Server on a spare computer with a broken graphic card, and I needed to setup my wifi.
I thought No problem, I've done it before from the command line, in Arch Linux., only the steps I had to take in Arch Linux didn't work in Ubuntu Server (that's odd, wasn't Ubuntu supposed to be so much more user-friendly? :/).
This is what I'd normally do:

ip link set wlan0 up
wpa_passphrase <ESSID> <WPA KEY> > /etc/wpa_supplicant.conf
wpa_supplicant -B -Dwext -i wlan0 -c /etc/wpa_supplicant.conf
dhcpcd wlan0

Only at the wpa_supplicant I get some strane message:

ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument

And if I try to run dhcpcd then (which I manually installed, as it didn't come preinstalled with Ubuntu Server), it times out.

Help on how to do it would be much appreciated.


My wireless driver is iwl3945.

share|improve this question
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  Seth Jan 13 '13 at 1:03
    
@iSeth It's abandoned. I gave up on Ubuntu Server. –  RobinJ Jan 14 '13 at 8:34
    
I had the same issue on Debian. It seems that it started when I installed network-maneger - I couldn't connect, and when I uninstalled it, it works again. –  Petr Pudlák Sep 24 '13 at 9:34
add comment

closed as too localized by fabricator4, fossfreedom Jan 13 '13 at 11:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

That is not the proper syntax for

network={
    ssid="your_essid"
    psk=your_key or passpharse
}

See : https://help.ubuntu.com/community/WifiDocs/WPAHowTo

share|improve this answer
    
... Then what is? I've tried the thingy with proto and key_gmgt but it makes no difference. –  RobinJ Feb 22 '12 at 20:25
    
I gave you the syntax and a link for additional information. If you need assistance, pastebin your configuration file and / or provide the information (your essid, etc). –  bodhi.zazen Feb 22 '12 at 21:22
    
From your link: "Unsupported Version: This article applies to an unsupported version of Ubuntu." –  phyzome Mar 12 '12 at 1:46
    
@phyzome - you should probably start your own question. You need to tell us what hardware you are having a problem with and what version of Ubuntu you are running. –  bodhi.zazen Mar 12 '12 at 1:50
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.