Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I been having problems with ubuntu, in that I can reach the login screen, but when I enter my password it comes up with a black screen with some text and takes me back to the login screen - I can login in terminal mode. After trying several fixes posted on the Internet I decided to just reinstall Ubuntu, since I don't have anything important on. However I did want to backup my Home folder. This folder was encrypted on installation. When I try to access it from the LiveCD version of Ubuntu, it displays a readme.txt file that tells me to run ecryptfs-mount-private. I run this and it displays the error 'Encrypted private directory is not setup properly'. Any solutions to both of these problems would be appreciated.

share|improve this question

I have tried all the methods listed in those posts, and I still can't access my files. I don't have my mount passphrase, and when I try to get it using ecryptfs-unwrap-passphrase /home/daniel/.ecryptfs/wrapped-passphrase but it comes up with the error:

Error: Unwrapping passphrase failed [-5]
Info: Check the system log for more information from libecryptfs

However, sudo ecryptfs-recover-private worked.

share|improve this answer
I was just about to chime in and recommend ecryptfs-recover-private. That's definitely the right way to go! – Dustin Kirkland Feb 23 '12 at 18:19
What did the system log have to say with regard to libecryptfs? – waltinator Jan 15 '13 at 19:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.