Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My GIMP is not opening any more, after trying to upgrade to 2.7 (I added the PPA to do that).

I got an error when trying to upgrade that said some dependencies couldn't be solved.

So I removed the PPA, removed GIMP altogether, and reinstalled the standard GIMP... installation went ok but now it won't open. How can I troubleshoot it?

Invoking gimp in a Terminal gives:

gimp: error while loading shared libraries: libbabl-0.0.so.0: cannot open shared object file: No such file or directory
share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Here we go:

sudo apt-get remove gimp
sudo apt-get update 
sudo apt-get purge gimp libgegl* libbabl* 
sudo apt-get install gimp 

This worked for me.

Source: http://bentwithlove.blogspot.com/2011/05/gimperror-while-loading-shared.html

And if you add the ppa

ppa:matthaeus123/mrw-gimp-svn

you can get the latest 2.7 gimp!

share|improve this answer
add comment

I had the ppa @Alex mentions installed, but my that gave me the same libbabl-0.0.so.0 problem like you.

If you are satisfied with gimp 2.6, the following worked for me (Ubuntu 12.04):

1) remove the matthaeus123 ppa。 As pointed out by @Eliah Kagan, the safer way to do this is:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:matthaeus123/mrw-gimp-svn

2) Do something like @Alex said. I did:

sudo apt-get remove gimp
sudo apt-get update
sudo apt-get purge gimp libgegl* libbabl*
sudo apt-get autoremove
sudo apt-get install gimp 
share|improve this answer
    
Thanks man, I was looking for a better way to remove ppas and I didn't know that you could mark a comment as obsolete. Do you need rep for that ( I can't even vote up ='(...)? I don't seem to find how to mark as obsolete. –  Ciro Santilli Jun 4 '12 at 7:34
    
You may want to edit your post again, to clarify that you've presented two separated techniques (rather than one technique with two steps). Also, please note that if your original technique worked and you didn't also manually remove the PPA from your Software Sources at some point, then you were probably still using the PPA. (I'm not sure exactly what you did or what happened, so I can't edit your answer myself to clarity this). –  Eliah Kagan Jun 4 '12 at 17:48
    
As for flagging comments as obsolete, if your run your mouse pointer along the left side of a comment there are upvote and flag buttons; you can flag as obsolete. You need 15 reputation to flag questions and answers, but my understanding was that there's no minimum rep for flagging comments. I could be wrong about that though. I'll look into this. –  Eliah Kagan Jun 4 '12 at 17:49
    
My idea was to show two steps that would solve: how to get GIMP back to work (2.6 however) after adding the ppa, which broke gimp for me. You could see them as two different techniques, but I thought that they were two steps required in order need to solve the problem. As for flagging, I don't even see place to vote up down the comments, probably need some more rep. –  Ciro Santilli Jun 5 '12 at 6:23
    
After running the commands listed under (1), performing the commands listed under (2) should be expected to do nothing. The commands under (2) might fix the PPA version of GIMP, or might even fix the non-PPA version of GIMP, but the commands under (1) should be sufficient to downgrade GIMP from the PPA version to the non-PPA version. –  Eliah Kagan Jun 5 '12 at 7:39
add comment

In my case none of the apt remove-reinstall commands were working, started to get it working by uninstalling, then removing leftover files (I had compiled gimp at some point earlier), which are reported with whereis gimp. Now after reinstall, it started up with error, second startup complained about files in /usr/share/gimp nonexistent. After apt-get purge and install of gimp-data and gimp packages, it works!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.