Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

sorry for my bad english but i'm french.

Well, i have this new ubuntu with unity and compiz just doesn't work.

As you can see i have everything i need checked : http://i.stack.imgur.com/aykyc.png

and : http://i.stack.imgur.com/uIEnV.png

But after this when i close, minimize or anything, nothing happends. I don't know what to do, i already have the driver for my graphic card.

Thanks ;)

share|improve this question
    
You could try this command in a terminal: compiz --replace & and see if there are any errors in the output. Then disown %1 so it doesn't die when you exit the terminal. –  Githlar Feb 22 '12 at 9:01
    
hello and thanks for your time. I'm getting few errors : –  mamouth Feb 22 '12 at 9:03
    
@Githlar i.imgur.com/l1bwe.png –  mamouth Feb 22 '12 at 9:09
    
It seems that compiz is not using my ATI card but my intel HD graphic. –  mamouth Feb 22 '12 at 9:16
    
I'm having the same problem I'm not sure how it's effecting your PC but my whole entire launch bar and menu bar is missing and when I use the command 'ccsm' and try to enable unity and disable anythings that my conflict it says it's enabled for a second but then it wants me to enable Expo, OpenGL, and Scale. but it always ends with them all automatically unenabling all the enabled plugins –  user154672 May 2 '13 at 4:17

1 Answer 1

I've had this problem before (unfortunately mine caused a kernel panic at boot)! If you're not using something like Bumblebee to save power (i.e. you're on a desktop) you can blacklist your Intel on-board video by adding this line to /etc/modprobe.d/blacklist

blacklist intel-agp

Then reboot

share|improve this answer
    
Humm It still doesn't work. I didn't have the /etc/modprobe.d/blacklist so i created it. But i had this one /etc/modprobe.d/blacklist.conf. I added the line at both files on by one and both at the ame time but it still doesn't work ... –  mamouth Feb 22 '12 at 16:41
    
Btw i tried this /usr/lib/nux/unity_support_test -p. But i had bad request. So i've come here : askubuntu.com/questions/81344/… –  mamouth Feb 22 '12 at 16:51
    
and in /etc/modpobe.d/fglrx.conf i can read : blacklist radeon –  mamouth Feb 22 '12 at 16:53
    
should i comment this line ? –  mamouth Feb 22 '12 at 16:53
    
I'm sorry. Before I did mean blacklist.conf. Actually, did you install the drivers with "Additional Drivers"? Or the official ones? If it's got a green light in "Additional Drivers," it means it's installed. Honestly, I had nothing but heartache with ATI cards in Ubuntu after the first two I gave up on them and used nVidia (they're much better supported). Then again, that was in 2007. But, I realized that some people don't have an option (i.e. Built-in on a laptop) –  Githlar Feb 23 '12 at 13:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.