Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I set Windows to boot as the default in the boot loader?

9 days ago I added Kubuntu 11.10 (Oneiric Ocelot) to Windows 7 on my computer. Since then I have spent 12 hours plus trying to change the default grub selection from Ubuntu to Windows. I have gotten several different kind of advice, but none of them work.

I have changed to GRUB_DEFAULT=5 and tried GRUB-DEFAULT "Windows......" But no matter what, when I restart, Ubuntu is again the one that starts as default.

When I open the text editor it clearly now states "Windows....." as default, and it also showed 5, when 5 was set as default, only when I start up the computer.... it is always ubuntu, unless I stand at the computer and when the page with the boot options comes (GNU GRUB version 1.99 - 12ubuntu5) I click down to the sixth and last entry, my windows....

How to make this work?

share|improve this question
add comment

marked as duplicate by fossfreedom Feb 22 '12 at 11:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

After changing that configuration file, you need to run sudo update-grub in a Terminal to make it take effect.

share|improve this answer
    
Well, of course I did that.... each time. And I had advice from several Ubuntu "specialists". As it says "GRUB version 1.99", does that mean it is not Grub2 ? –  Tyler DV Feb 22 '12 at 9:13
    
Ok, you just didn't say you had so it wasn't clear. You should point out everything you've done in the question. GRUB version 1.99 is GRUB2. –  Caesium Feb 22 '12 at 14:37
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.