Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from 11.04 to 11.10. I have several external hard drives, and now I cannot change anything on them: the permissions have seemingly been altered to read-only.

When I look at the "Properties" of each drive in Nautilus, it shows me as the owner, yet I can only "Access files". When I try to change this to Create and delete files, it shows an error message "Sorry, could not change the permissions of "124E43F04E43CAE5": Error setting permissions: Read-only file system".

I have tried to alter file permissions by starting Nautilus with "gksudo nautilus", but it doesn't work. I have tried to change permissions for the whole drive using the chmod command in terminal. Still no success.

I am not a noob, but I am at a loss as to what to do next. Can anyone help? My back-up destination is one of the external drives, and I cannot back-up until this is fixed.

Thanks in advance.

share|improve this question
    
Please mark your answer accepted using the check-mark, thanks –  Ringtail Feb 22 '12 at 5:16
add comment

2 Answers

up vote 0 down vote accepted

If the external drives are formatted in NTFS, most of the time they are, you will need to install ntfs-3g and ntfsprogs to access with write permissions.

sudo apt-get install ntfs-config

To verify use gparted or sudo fdisk-l and determine the formatting.

This is a good reference for you to look at: https://help.ubuntu.com/community/MountingWindowsPartitions?action=show&redirect=NTFSReadWrite

share|improve this answer
    
Thanks, this has seemed to work. I installed ntfs-config, and now when I plug in the drives, I can now correctly create and delete files. Not sure what it has done to the file-manager, but it has worked. –  Reggie Feb 22 '12 at 1:08
    
Good then my answer was acceptable. –  Ringtail Feb 22 '12 at 1:53
add comment

It seems to be the case that your drive is mounted as read-only. Say your drive is /dev/sdb then you need to unmount it umount /dev/sdb and mount it again mount /dev/sdb <directory>

If this does the trick, and you want the drive to me mounted at all times, you may want to add an entry in fstab.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.