Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have some files and folders that I can't delete. I click menu -> right click and the delete option is not available.

I can delete by using the terminal, but I'd prefer to do it from the GUI.

It's something to do with permissions, can someone help?

share|improve this question

Make the current user owns everything inside the folder,itself as well as the parent folder.

chown $USER -R /desired.folder
share|improve this answer
ok, but what about the rest the files in system. I can't delete anything in desktop, home folder, even on partitons – Matt Feb 21 '12 at 19:19
some one messed up ur permessions i think you need some one advanced.... i recommend booting live medium again and repairing ur existing installation – sarveshlad Feb 21 '12 at 19:26
found it in termian - sudo chmod +s /usr/bin/avrdude and ls -al /usr/bin/avrdude thats all. I even cant remeber from when i can't use delete cut and move to option ... – Matt Feb 21 '12 at 19:34
you have to run that command in terminal just ur home directory and other partition should have all access dont mess with other direcotry partitions – sarveshlad Feb 21 '12 at 19:39
i run it in right directory;/ – Matt Feb 21 '12 at 19:56

For those particular cases I use nautilus as root: Press Alt-F2 and type:

gksu nautilus

Then proceed with caution, you may seriously damage your system.

share|improve this answer
Hmm... good solution but why i can edit files on ubuntu partition but i cant do in on the rest ntfs partition;/. Is is possible repair it? – Matt Feb 21 '12 at 22:10
Matt, as root you're supposed to do everything. However, you can't change owner or permissions on ntfs partitions, I had a similar problem and fixed it adding my user to the group that owned the ntfs file system... – th3pr0ph3t Feb 23 '12 at 17:31
hell yeah! i had turned off write option in NTFS manager... lol! – Matt Feb 24 '12 at 22:02

If you want to remove file and folder from terminal you can use

rm <filename>

delete folder

rm -rf <foldername>
share|improve this answer

change the name of the folder that contains those files or folders.

for example: The_name_of_the_root_folder_that_contains_the_not_manageable_files change it to 1 or Name

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.