Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My hardware is pretty new; I've installed Lubuntu 11.10 and there's no sound nor volume icon in tray. The sound works well in Ubuntu. What can I do about it? I have two sound cards in this laptop, and one of them is HDMI, maybe the problem is because of that? Please help me?! Thanks.

share|improve this question

4 Answers 4

I finally got sound working on HDMI. It was very interesting find though.

I saw differences in Pavucontrol without a video playing and with a video playing.. All i had to do was open Pavucontrol with a video playing and then select output to HDMI card.

Hope this helps all..

share|improve this answer

Lubuntu unlike Ubuntu does not make use of Pulseaudio. Instead it uses Alsa for sound.

Thus, it is likely you need to look at alsamixer or its gui alsamixgui to control which sound elements are enable or disabled.

You may also need to look at using alsamixer as a startup application with the syntax similar to

amixer -c 1 sset "PCM Capture Source" "Line" - obviously you need to change the values to your sound source and output type.

Also - look to see if you have two sound cards - if you have, sometimes swapping the cards works:

sudo su
cd /usr/share/alsa 
cp -p alsa.conf alsa.conf.dist 
sed -i 's/card 0/card 1/g' alsa.conf

I answered a LXDE sound-preferences question a while back which you may find useful.

As indicated in that answer, you could also install pulseaudio and use pavucontrol to control your pulseaudio setup.

As to a LXDE friendly volume control, my answer here is an accepted method you can try.

share|improve this answer
1  
$ sudo bash cd /usr/share/alsa cp -p alsa.conf alsa.conf.dist sed -i 's/card 0/card 1/g' alsa.conf That solved my sound and my volume tray problem. But how can I get volume indicators on screen, when I turn the volume up/down? Thanks –  marcel Feb 21 '12 at 16:08
    
see my final edit. hope this helps. –  fossfreedom Feb 21 '12 at 16:11

This is what I did to fix the issue:

Lubuntu shares many components with XFCE. My suggestion would be to use the XFCE4-Mixer. This still gives you a lightweight solution compatible with the lxde ethos.

to install

sudo apt-get install xfce4-mixer gstreamer0.10-alsa

This installs the following limited number of xfce packages:

exo-utils libgarcon-1-0 libgarcon-common libwnck-common libwnck22 libxres1 xfce4-mixer xfce4-panel

to run

Type xfce4-mixer in a lxterminal. In Options, in the Auto-Mute Mode drop-down menu, select "Disabled."

Credit: This is a close but not exact derivative of this answer by fossfreedom and anonranger.

share|improve this answer

This may help: http://forum.xbmc.org/showthread.php?tid=76544&pid=1069025#pid1069025

share|improve this answer
5  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Apr 7 '12 at 17:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.