Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

While trying to install rubygems 1.3.7 from the Maverick repository (Lucis has 1.3.5) I am getting the following error:

Error: Breaks existing package 'rubygems' dependency rubygems1.8 (= 1.3.5-1ubuntu2)

Is there a way to override this, even though it may not be recommended.

share|improve this question

1 Answer 1

You may try using ppa:maco.m/ruby PPA

Another option is to build it from source (using instruction from here):

sudo su
apt-get install build-essential
apt-get install ruby rdoc libopenssl-ruby
wget http://production.cf.rubygems.org/rubygems/rubygems-1.3.7.tgz
tar zxvf rubygems-1.3.7.tgz
cd rubygems-1.3.7
ruby setup.rb
ln -s /usr/bin/gem1.8 /usr/local/bin/gem
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.