Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I plug in headphones, my speakers mute, but nothing comes from the headphones. Also, there is a weird red light coming from my headphone jack. I am on a Macbook from late 2007, and have Ubuntu 11.10. Thanks!

share|improve this question

4 Answers 4

I have the same problem since a week ago, on a Dell Studio XPS, also on 11.10. In the past I usually fixed it by adding

options snd-hda-intel model=dell-eq or options snd-hda-intel model=dell-m6

to /etc/modprobe.d/alsa-base.conf

but it's not working anymore.

share|improve this answer
    
Well, all of a sudden it's working, after doing the DKMS below and the options snd-hda-intel model=dell-m6 above, for the hundredth time. Go figure. –  Eugenio Perea Feb 27 '12 at 0:22
    
First option solved this for my Dell studio XPS Studio 1647 –  Kyle Brandt Mar 11 '12 at 0:29

This is because the headphone output is controlled by the 'Speaker 1' volume, which is muted by default. To solve this, install alsamixergui and enable the 'Speaker 1' volume.

share|improve this answer

I have a LG E500 with Ubuntu 11.10, I had normal sound on speakers, but when plug in headphones they mute, and to turn on sound I had to mute and unmute at the sound menu. So I found this easy solution,just installing a .deb package. I hope that it helps you!

https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

Cheers!

share|improve this answer

Just to cover all your bases, have you checked the output volume for your headphone jack? In a terminal run alsamixer. Use left/right arrow keys to scroll through the channels, up/down to adjust the levels.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.