Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Tried the Nvidia driver, installed using the Additional Drivers panel. Didn't like it much; the CPU seemed to overheat more and the brightness controls stopped working. Also selecting a second display is a pain using that horrible NVidia settings thing.

So wanted to disabled it again.. problem is, UBuntu is then stuck in either 640x480 or 800x600 (second time I tried to install it back and then remove again).

How can I get this back the way it was? The original Ubuntu drivers worked just fine, allowing me to run Unity and games properly. I tried a xserver-xorg reconfigure but this didn't do anything. (No xorg.conf file either).

This is on a Lenovo Thinkpad T410i

enter image description here

enter image description here

share|improve this question
    
Can you check if your xserver-xorg-video-nouveau package is still installed? This is what it should be using (if not the NVidia binary driver). dpkg -l xserver-xorg-video-nouveau should have a line at the end starting ii if it's installed. –  Caesium Feb 21 '12 at 3:31
    
Thanks; this doesn't solve the problem. The Nouveau driver was still installed. To be sure I removed it using the --purge option and then installed it again. I get teh right resolution now but still I get random behavior of the display: flashes, flickering, random artifacts appearing and disappearing everywhere. –  Han Cnx Feb 21 '12 at 9:12
    
Update: This is what I'm looking at currently; note the strange artifacts; these jump all over the place when I move a window. incm.info/images/screenshot1.png incm.info/images/screenshot2.png –  Han Cnx Feb 21 '12 at 9:33
    
possible duplicate of How can I remove nvidia drivers? –  Lekensteyn Feb 27 '12 at 20:32
add comment

3 Answers 3

if your laptop has another onboard vga, use it instead of nvidia card...

Use bumblebee to solve the problem... it will automatically diagnose and solve your probs.

steps: open terminat and type:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia

for more instructions https://github.com/Bumblebee-Project/Bumblebee/wiki/Upgrading-on-Ubuntu#wiki-install

share|improve this answer
    
Thanks; this doesn't solve the problem. The Nouveau driver was still installed. To be sure I removed it using the --purge option and then installed it again. I get teh right resolution now but still I get random behavior of the display: flashes, flickering, random artifacts appearing and disappearing everywhere. –  Han Cnx Feb 21 '12 at 9:10
    
I added the repository and it shows in my /etc/apt/sources.d directory, but it cannot find the bumblebee or bumblebee-nvidia package. –  Han Cnx Feb 21 '12 at 9:16
    
Update: I don't think the nouveau driver is being used.. I removed xserver-xorg-video-nouveau and then restarted LightDM, and it behaves exactly the same. Potentially some other driver is being used? It's pretty unusable right now, I'm looking at screen-soup. ;) It takes a lot of clicking to get to this text box in my browser. –  Han Cnx Feb 21 '12 at 9:19
add comment

Make sure your nouveau driver is not black-listed.

I had the same problem as you after installing the NVIDIA driver manually and removing it after not enjoying it.

You need to take a look in your /etc/modprobe.d folder. You may well find a file named something like "nvidia-installer-disable-nouveau.conf". You will need to be root to delete this so fire up a terminal and punch in:

sudo rm /etc/modprobe.d/nvidia-installer-disable-nouveau.conf

Obviously change this to whatever your file is called, if different. After that reboot and you should be good to go! I didn't use the restricted driver installer though, I downloaded the driver straight from NVIDIA so the file may be different or the lines:

blacklist nouveau

options nouveau modeset=0

May well be in a different file, so have a nosey around the modprobe.d folder.

Hope that helps.

share|improve this answer
add comment

I have a w510. unity(ubuntu 14.4) hangs intermittently.

I installed the bumblebee software and that made it worse.

Xorg would fail to start completely. I then tried a lot of things, installed nvidia-331, reinstalled the nouveau driver(which was the initial issue with the intermittent hangs).

The solution above worked for me. It turns out, the bumblebee stuff made a bumblebee.conf file in /etc/modprobe.d/ which black listed nouveau and nvidia drivers. I removed the file, rebooted. then installed nvidia-331, rebooted (a lightdm would prbably do the trick too) and all is well again. :)

cheers

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.