Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Just installed Ubuntu 11.10 yesterday (Feb19) and I have noticed that Banshee will not play MP3's at all.

The Ubuntu Restricted file will not install either.....something about not being in my software sources. A few people have recommended this file to me, however, it's not available to install.

Seems to me that it shouldn't be this difficult to get MP3's working in this age!

share|improve this question

I think not all of your software sources are activated. The software is organized in different sources, which are 'main', 'universe', 'restricted' and 'multiverse'. Main contains open source software, supported by Canonical. The software in universe is maintained by the community. Restricted contains proprietary drivers and in multiverse is software which is restricted by copyright or legal issues.

It seems, that some of this sources are not activated. To do so, go to 'System Settings' -> 'Software Sources'. In the tab 'Ubuntu Software', check all boxes, except 'Source Code' and Cdrom.

Then you have to install the packages gstreamer0.10-fluendo-mp3 and*gstreamer0.10-plugins-ugly* in Ubuntu Software Center

share|improve this answer
worked for 14.04 – Aquarius Power May 20 '14 at 22:08

Installing Medibuntu will solve your problem... After installing this package you will not only able to play mp3s but any media format you wish to play.(using bunshee or any other player)

Installing Medibuntu

The following bash command adds Medibuntu's repository to Ubuntu. It also adds Medibuntu's GPG key to your keyring, which is needed to authenticate the Medibuntu packages.

This command should be run in the Terminal (Applications → Accessories → Terminal): 

sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

Medibuntu's repository is deactivated by upgrading to a newer Ubuntu release, so you should run this command again after the release upgrade.

You may also wish to add the following packages. The first will cause many apps from the Medibuntu repository to appear in Ubuntu Software Center. The second will allow users to generate crash reports against Medibuntu packages and submit them to the Medibuntu bugtracker.

sudo apt-get --yes install app-install-data-medibuntu apport-hooks-medibuntu

Please note you may have to use --force-yes instead of --yes in order for this command to succeed.

Another good option.

Instead of tyrying above steps...

Just open ubuntu sofware center and install VLC player. And make it your default player. You will be able to play any file format you wish to plat.

share|improve this answer

Often all you need to do is to install lame: sudo apt-get install lame

share|improve this answer

Regarding Banshee media player, I worked out a solution.

In Ubuntu 14.0.3, via Synaptic package manager, I (re)installed gstreamer0.10-ffmpeg/-fluendo-plugins-mp3-partner/-plugins-base/-plugins-good/-plugins-ugly/-pulseaudio & gstreamer1.0-fluendo-mp3/-libav/-plugins-base/-plugins-good/-plugins-ugly/-pulseaudio/-x, & everything works well, including video playback.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.