Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The apt-get autoremove command does not have any effect in Maverick. How can I solve that?

EDIT: Restoring a VM backup containing a clean install solved the problem.

share|improve this question
What does it means? You can see packages to remove but autoremove doesn't work? – skalka Oct 31 '10 at 18:42
Yes, exactly that. There are packages to remove, but the autoremove don't do squat. – lovinglinux Oct 31 '10 at 18:50
This question would be easier to address if you gave some detail. What packages are tagged for autoremove? Is the package actually installed? dpkg -l package-name can cross-check what apt-get lists as not needed. Does removing a specific package yield a different result (e.g. apt-get remove package-name)? What does apt-get check have to say for itself? – msw Oct 31 '10 at 20:04
The packages are installed, because they were installed as dependency of another package, which has been already removed. I have executed autoremove just after removing it and receiving the alert about packages that were not needed anymore. Besides, there were several packages in the Computer Janitor list. I can't run those commands now, because I have already reset the virtual machine, but I still want to fix this issue. – lovinglinux Oct 31 '10 at 20:12
Do you have a file /etc/apt/apt.conf.d/01autoremove? Autoremove was borked during the Maverick dev cycle, so maybe you ran into some kind of upgrade problem? – htorque Oct 31 '10 at 20:44

Go to System > Administration > Computer Janitor. You can find all the packages that can be removed.

But, I am not sure whether it happens in 10.10

share|improve this answer
Thanks. However, I would really like to restore the autoremove functionality, because I don't trust Computer Janitor and also prefer to do it via command-line. – lovinglinux Oct 31 '10 at 19:18
Me either. But, I am on Ubuntu 10.04. I have no idea regarding that. :| – Vinay Challuru Oct 31 '10 at 19:43
I'm also on 10.04 and won't upgrade. The problem is occurring on a VM I use for testing me applications. – lovinglinux Oct 31 '10 at 21:53
up vote 0 down vote accepted

Restoring a VM backup containing a clean install solved the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.