Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 11.10 and I'm new to Linux family. I have a problem with logging in to it. After I enter password and press enter it says:

Could not connect to session bus: //bin/dbus-launch terminated abnormally without any error message

According to this question "could not connect to session bus" on login I tried to login as guest user and succeeded. So it's "definitely a problem with my home folder". And O think I know what the problem is.

The question is: how can I get access to my home folder?

share|improve this question
add comment

3 Answers 3

up vote 0 down vote accepted

I found this post on the ubuntu forum: http://ubuntuforums.org/showthread.php?t=1232886.

But let's try other thing, do this;

sudo -i

then go to /homeand do ll

you will see something like this:

:/home# ll
total 4
drwxr-xr-x  6 root    root     128 2012-01-31 09:26 ./
drwxr-xr-x 25 root    root     704 2012-02-13 07:31 ../
drwxr-xr-x 81 marcelo marcelo 3008 2012-02-20 20:08 marcelo/
drwxr-xr-x 20 test    test     784 2012-01-31 13:10 test/

you us what you see in yours.

in mine there are 2 users: marcelo (me) and test (for other reasons). inside your folder do ll again and let's see how is the owner o that folder.

you can do (as root) chown user folder/ and chgrp group folder/

In my case to change the folder /test to me and my group "marcelo" is this way:

chown marcelo test/
chgrp marcelo test/

Hope it could be helpful.

share|improve this answer
    
Thank you for the post about setgid:operation not permitted. About the other thing 'sudo -i' it shows error 'unable to change to sudoers gid'. –  Alberto Feb 21 '12 at 12:01
add comment

Problem is solved. Since I wanted only to get access to my home folder, I used ubuntu livecd to boot and modify /home/{username} folder contents. I haven't faced all these problems that were described. As I suspected the problem with logging in happened because of incorrect configuration of pam_environment file. I used this help page https://help.ubuntu.com/community/EnvironmentVariables to create file

/home/{username}/.pam_environment

with the following contents

MAVEN_HOME=/home/{username}/java/maven2

PATH=$MAVEN_HOME/bin:$PATH

May be this will be helpful for somebody. How to make configuration work - I guess this is another question.

share|improve this answer
    
great! this could be very helpful! –  maniat1k Feb 21 '12 at 12:42
add comment

You can log in as guest and then execute the command su - username from shell (replace 'username' with your user name). It will ask you for your password and afterward you will be able to access your home directory.

share|improve this answer
    
This is not working. It says 'setgid: Operation not permitted'. –  Alberto Feb 20 '12 at 22:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.