Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

my question is how can I upload my source package ( I already got the .sources file) over the active ftp method with dput to my launchpad ppa?

my .dput.cf file looks as follows:

[cooking]
fqdn                    = ppa.launchpad.net
method                  = ftp
incoming                = ~gotwig/lens-cooking/ubuntu/
login                   = anonymous
passive_ftp             = 0

my command is

dput cooking lens-cooking_0.1_source.changes

The traceback is:

Good signature on /home/gotwig/lens-cooking_0.1.dsc.
Uploading to cooking (via ftp to ppa.launchpad.net):
Uploading lens-cooking_0.1.dsc: 425 Can't open data connection.

It seems to me, as it want to use passive_ftp instead of active one.. I cant use passive ftp becouse of my router.

If there is a way without a configuration file, I would be even more happy.

share|improve this question
    
Note: I am now using launchpad recipes, so I dont have to use dput in this case. –  Eduard Gotwig Feb 21 '12 at 6:58
add comment

2 Answers 2

Are you sure your router disallows passive FTP? it's usually the other way around, and the trace indicates it has trouble opening the data connection (as opposed to the commands connection) - this further reinforces the belief that the router is also blocking active ftp.

You can use the --passive parameter to dput. As you mention below, active is the default.

If not, you may want to look into using SFTP (assuming it's unblocked by your router) as a transfer method. See here for more details: https://help.launchpad.net/Packaging/PPA/Uploading

share|improve this answer
    
"-P, --passive - use passive ftp instead of active. Note that passive ftp is the default unless specified otherwise in the configuration file." says the man page - clearly –  Eduard Gotwig Feb 21 '12 at 6:57
    
I'm really sorry, I completely misread. Amended the answer. –  roadmr Feb 21 '12 at 16:22
add comment

That config file should get you attempting active FTP, if it doesn't, it may be a bug. Launchpad uploads over both passive and active work for me.

I recommend using sftp, its better all around.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.