Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Under Compiz :: General Options :: Desktop Size I already have 2x2 layout of 4 virtual desktops setup, as in screenshot.

1x1 virtual desktop problem

However if you notice as in the switcher app parked in the top left corner, only one desktop shows, and indeed only one is available to send windows to or hover over to.

Right-clicking that docked switcher to "Add a workspace" doesn't behave right anymore. It's like the desktops are too independent and trying to send windows to Right/Down isn't an option anymore from the Alt Space menu. Nor do hotkeys CTRL-ALT-Arrow work to slide over anymore. Double-Clicking does switch desktops though, but it's like they're in otherwise unrelated Xwindows sessions(cannot be, of course).

For a while I've been stuck with a stubborn 1x1 or 1xN layout, unable to figure out why it won't go to 2 columns, until I discovered the Compiz :: General Options :: Desktop Size :: "Number of Desktops" had mysteriously gone to 0. Horizontal and Vertical were both still 2 there. (Weird things happened when I next made that 0 into 4--Switcher at first drew 16 virtual desktop boxes, after which I decided to collapse everybody into 1 desktop and start again from there.) My ~/.dmrc contains only:


I noticed each has a title now: Work / Game / Video / Chat, maybe they were present before I had to reboot from a total Xwindows unresponsive freeze(though switching back and forth from text consoles Ctrl Alt F1-F6 still worked) twice, but I don't recall titles before.

After some updates to cairo-dock and many other packages since Feb, notice 16 workspace boxes manifested themselves again, though only 4 seem switchable via ctrl-arrow keys: erroneous 16 virtual desktops??

share|improve this question

Turns out the virtual-desktops layout setting in ccsm may not be the same as when you right-click on the virtual-desktop app, wishing to add or remove workspaces. Can't seem to PrtSc while viewing the right-click menu of the upper left switcher/workspace/virtual desktop preview app, but the 3rd and 4th items down the list are Add a workspace and Remove last workspace.

So I selected the Remove last workspace a few times till it returned to the 2x2 layout, and consistent with what's actually in ccsm

UPDATE (again)

To spare others aggravation & unclear documentation(if any) the Switcher applet and CCSM virtual workspace/desktop settings indeed are independently-minded. Not only that, their initial appearance after a fresh startup may actually be different than how they will behave. For instance, the Switcher applet docked in my upper-left corner in the screenshot, showed a big 1 and only one single box at first, but as soon as you try sliding to another desktop, it magically updates to show boxes 1-4. This glitchy startup appearance had me definitely fooled before, troubleshooting configs in vain, when it probably was ready to behave all along.

For now I recommend keeping CCSM at 1 virtual desktop not 4, and instead let Switcher manage your 2x2 or whatever layout. Shortcuts etc. finally seem to remain more consistent across restarts this way, for me, and now I know to disregard the initial appearance of only one desktop.

share|improve this answer
Problem still not solved...even though that widget shows 4 desktops arranged 2x2, ctrl-arrows only allow me to go up and down to 2 virtual desktops, not sideways....arrrgg... – Marcos Mar 4 '12 at 21:10

The number of desktops should be 1 in compiz. Zero is an illegal number and cannot normally be used. It's a bit confusing, and I've personally never found a use for any number other than 1.

I used to use Cairo dock, and it worked fine, using the Compiz settings. Adding a new workspace would add a new row, which in your case should give you 3 rows x 2 columns.

share|improve this answer
Good observation. Something must have been messed somewhere prior. After switching out of 0 that UI won't let you reduce below 1 again, which is fine. – Marcos Feb 21 '12 at 8:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.