Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In recent Ubuntus the menu has been pulled up into Unity's panel. That's great, but it's not for me. I'm using the Gnome 3 fallback panels for my desktop and like my menu's like they always were.

Just using the fallback/Classic mode does most of what I need. Applications have their menus attached but only after a short delay. It's as if they start without the menu and then the menu is added back after it realises there's no Unity to handle it.

Normally this wouldn't be catastrophic for anything but it's really annoying for Image viewer and other things that spring up their window based on the size of some media, only to have a menu jump in and ruin everything. Here's an example I risked my life to record and show you today:

enter image description here

How annoying is that?! It goes from 100% (lovely) to a cruddy 94%!

So, yes... How can I make it so when windows load, they do it like they used to, without the menu popping up seconds later, after it's finished its cup of tea?


I thought running with the UBUNTU_MENUPROXY explicitly set might help:

 UBUNTU_MENUPROXY=0 eog 20120215-psychonauts.png

But it doesn't. Same delay.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Best just remove the indicator-appmenu package, as per instructions on this answer : How do I disable the global application menu?

As far as I can remember, this may break ubuntu-desktop but as I'm sure you know, that's just a meta-package and shouldn't be the end of the world, except perhaps during upgrades where it might be wortwhile adding it back in.

p.s. I recommend installing gthumb and using that instead of eog generally, as you'll get much the same experience, but with the added benefit of some basic image manipulation if you ever need (without having to launch the heavy-handed Shotwell to do so). Just a thought.

share|improve this answer
    
Yeah I've already followed several of those suggestions (and others). To be fair - they work to the point where the menus are attached to the applications but even after removing the various indicator-appmenu packages, it's as if the menu has to be teleported in after the application has loaded. –  Oli Feb 20 '12 at 15:06
    
I despise Global Menu, so will remove it when I get home tonight on my 12.04 laptop. I'll update on whether I get the "pause" like your animation. Although I notice that I'm getting huge pauses when mouse clicking on Firefox bookmark groups at the moment, so perhaps it's related? To replicate, Open Firefox, show the Bookmarks Toolbar, right click on it to create a new folder, stick some bookmarks in it, then click on the folder to open it. On my 12.04 box, it takes nearly two seconds to show the contents. Infuriating. –  Scaine Feb 20 '12 at 17:06
    
Ohoh! Not only are menus instant for me now, removing that package has also fixed my Firefox issue. Great stuff, even if it hasn't helped you, Oli! :-) Might be worth a shot though. All I did was sudo apt-get remove indicator-appmenu. It was the only package that required to be removed and it didn't require the removal ubuntu-desktop. –  Scaine Feb 20 '12 at 19:12

The suggested fix seems to work in 12.04 (image stays at 100% zoom):

UBUNTU_MENUPROXY= eog image.png

More options for how to disable global menu:

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.