Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I was in the process of restarting the system last night and it seemed to lock up at the Ubuntu logo that normally appears when restarting or shutting down.

So after waiting an hour or so to restart, I decided to hit the power button to shut down the system. After doing so and pressing the power button once again to start the system, I selected the Ubuntu partition (dual boot machine) and it now doesn't boot at all. I can boot the other OS, which is Windows 7 ok.

There are a list of I guess internal commands listed on the screen and the last command was "Stopping Mount network filesystems [ OK ].

I've tried hitting Ctrl + Alt + Del and the system will restart but will get locked up again on boot.

Is there anything I can? I've had this happen before and being a newbie I just reinstalled the system but after this happened again, I really don't want to reinstall.

Suggestions are always welcomed! Thanks!

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Actually, it sounds like the problem you're having might have to do with your initialization commands.

Did you install anything prior to this happening?

Try this: Boot up off the Ubuntu LiveCD (use the Try Ubuntu option) and open a Terminal and Files: Click your Ubuntu disk in Files, then close Files. In the Terminal:

Type:

rootfs="/media/$(cat /etc/fstab | grep "/media.*ext4" | awk '{print $3}'`

Then:

sudo mount --bind /dev "$rootfs/dev
sudo chroot $rootfs
mount -t sysfs none /sys
mount -t proc none /proc
mount -t devpts none /dev/pts
update-initramfs -k all -c
umount /sys
umount /proc
umount /dev/pts
exit
umount "$rootfs/dev"
cp "$rootfs/var/log/apt/history.log" /home/ubuntu

Then, before you restart post the last couple sections of the "history.log" file in the home folder.

share|improve this answer
    
Yeah, I believe there were some updates that were installed prior to restarting. What those updates were, I'm not sure anyway. –  Muhnamana Feb 20 '12 at 15:51
1  
If you grab that /var/log/history.log we can see what the updates were. –  Githlar Feb 20 '12 at 16:09
    
I'll try this when I get home tonight. –  Muhnamana Feb 20 '12 at 16:16
    
Ok, so I was able to boot off the livecd, but where is this terminal and files at? –  Muhnamana Feb 20 '12 at 23:14
    
I did those list of commands, not sure anything worked, just because I'm not familar with it. The log file was never saved to /home/ubuntu but found the /var/log/apt/history.log but everything was from 2011-10-11 or something along those lines. –  Muhnamana Feb 20 '12 at 23:23
show 4 more comments

You didn't mention if you could boot your 'other' OS. If you can, then, barring something really obscure, you can discount a problem with the hardware.

If a laptop, -this will sound nuts- try closing your machine down, disconnect the power cord and then remove the battery. If a desktop, close down and disconnect the power cord. Wait 10 minutes and then replace battery and power cord. Then try a restart. If lucky all will go fine. Just don't ask me why it sometimes works: I'd guess it lets some capacitor or other drain down.

If no go, try this:- You didn't say if your machine is using grub or grub 2. Grub is pretty much on the way out so I'm going to assume you're on Grub 2. This is a little problematic because although you can possibly boot from Super Grub2 disk (the one I use as a standby is v1.98), it can't repair Grub2, just boot it. Since the object of the exercise is to find if you have a bootable system, just boot from the CD (download and burn first!) and a list of options will appear. The top one will likely be something like "Detect any OS". Select that and see what happens.

With luck you'll see what appears to be a normal Grub2 screen. Select Ubuntu and see what happens. If the machine boots normally, then likely you have a grub problem and you need to repair Grub2. There are plenty of ways to do this, but one of the neatest once your machine is running courtesy Super Grub2 disk is to installthe Boot Repair utility. Open Terminal and enter:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

This adds a ppa to your repos list.

Now enter

sudo apt-get install -y boot-repair && boot-repair

This installs Boot Repair and runs it. That may do the trick for you in short order.

I hope this helps. Good Luck!!

share|improve this answer
    
Thanks for your suggestion. I edited my question to include that I can boot the other OS on the partition. I'll try this tonight after work and report back if it worked. –  Muhnamana Feb 20 '12 at 15:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.