Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello people from AskUbuntu:

As the title says, even though I can access the internet, for some reason, I can't ssh/ping computers in my LAN. In addition, only computers from outside the LAN can ssh to my computer. This problem started when I installed Ubuntu 11.10 (this problem was not present when I was using Ubuntu 10.04).

I have tried restarting and even disabling ufw. Changing the subnet mask and/or gateway ip address results in loss of internet connectivity. I've tried using the second ethernet port to no avail.

I have looked for solutions online but many of those solutions are for the reverse problem (not being able to access the internet). I honestly don't know what to do. I have even tried turning the computer off and unplugging the power for a few seconds.

Maybe I'm using incorrect search keywords. I hope you guys can help me or teach me how to fix this.

Thank you for your time!

Edit 1: I've changed the first 3 numbers of the ip addresses below. 110.22.112.11 is the gateway and 110.22.112.91 is my ip. "ip route show" outputs this:

default via 110.22.112.11 dev eth1  proto static 
default via 110.22.112.11 dev eth0  metric 100 
110.22.112.0/24 dev eth0  proto kernel  scope link  src 110.22.112.91 
110.22.112.0/24 dev eth1  proto kernel  scope link  src 110.22.112.91  metric 1 
169.254.0.0/16 dev eth0  scope link  metric 1000
share|improve this question
    
Could you post the output of ip route show? –  Jeremy Kerr Feb 20 '12 at 4:51
    
Ok. I have edited my question to include the output –  Damian Feb 20 '12 at 5:28
    
do a tracepath www.google.com.I'm assuming www.google.com is reachable. –  Vineet Menon Feb 20 '12 at 5:50
    
Shutting down eth0 solved my problem. –  Damian Feb 20 '12 at 6:07
add comment

1 Answer

up vote 1 down vote accepted

This will be easier to resolve if you have only one interface up.

Try shutting down eth1 and then show the output of both: ip addr ls and ip route show (again).

share|improve this answer
    
Thank you so much. Shutting down eth0 solved my problem. I don't understand why though. Do you have any idea? –  Damian Feb 20 '12 at 5:59
    
the output of "ip route show" had the same src address listed for both eth0 and eth1. Potentially packets from within the LAN were sending responses to the wrong interface. Traffic to/from networks outside of the LAN would travel through a router or nat device which could mask the problem by ignoring traffic with bad src routing. –  JasonD Feb 20 '12 at 23:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.