Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Nvidia drivers in a thin client (LTSP) image using chroot on a Ubuntu 10.04 system.

I have been following the tutorial https://help.ubuntu.com/community/UbuntuLTSP/AtomIon

The commands I used;

$ sudo su
# export LTSP_HANDLE_DAEMONS=false
# chroot /opt/ltsp/i386
# mount -t proc proc /proc
# apt-get update
# apt-get install linux-source-2.6.32 linux-headers-2.6.32-24-generic
# apt-get install nvidia-glx-185
# exit

The error message I keep getting is:

Loading new nvidia-current-195.36.24 DKMS files...
First Installation: checking all kernels...
It is likely that 2.6.32-24-generic belongs to a chroot's host
Building for architecture i686
Building initial module for 2.6.32-24-generic
Done.

nvidia-current.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/2.6.32-24-generic/updates/dkms/

depmod....(bad exit status: 1)

DKMS: install Completed.

I've tried to reinstall and reconfigure but it doesn't want to run 'depmod' again.

How can I fix this problem and make it so nvidia drivers load for my current thin client kernel (Linux mythserver-desktop 2.6.32-24-generic)?

share|improve this question

closed as too localized by Eric Carvalho, Eliah Kagan, Thomas W., Basharat Sialvi, vasa1 Apr 9 '13 at 3:23

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
have you tried installing the original drivers from the nvidia website? You could try downloading and installing the driver directly from nvidia and see what the result is. The error message you are getting seems to be pointing to the nvidia-current.ko module, it's complaining that the module cannot be found in the kernel which is correct because the driver is propriety. There is mention of your problem here: bugs.launchpad.net/nvidia-drivers-ubuntu/+bug/556736 –  kingmilo Feb 20 '12 at 8:41
    
I'm still looking for a solution to this problem. We are using intel based graphics cards at the moment but I would like to get this problem fixed. –  map7 Feb 7 '13 at 10:43
add comment

Browse other questions tagged or ask your own question.