Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since I installed Gnome Shell (which I much prefer over Unity), there has been a small annoyance appearing on the right side of my screen.

As you can see in the picture below, there is a blank few pixels on the right side of the screen. It goes away if I reload gnome-shell ("r" command), but obviously, I'd prefer that this is not necessary. I'm not sure what exactly is causing this, but was hoping someone might be able to help.

Example of edge gnome shell problem

I'm running Ubuntu 11.10 on a Lenovo Thinkpad Edge E420s

share|improve this question
    
This is certainly not normal behavior. I can't start to assume what the problem could be(e.g video drivers possibly) but I would reccomend trying to first disable the user theme extension, or just change back to the default theme. –  l300lvl Feb 19 '12 at 22:36
    
@l300lvl, thanks for the suggestion, but unfortunately that didn't help... I noticed on a reboot though that it is fine, and then it looks like the desktop 'resizes' itself, and the space appears. I'm not sure exactly what process controls how the desktop loads... –  jat255 Feb 20 '12 at 5:33
    
I personally haven't ever seen it. I was thinking though, it could be a number of things. Have you ever experienced the problem in Windows? Can you check your display/resolution settings and possibly try setting them to something lower? Also, have you ever played with randr/xrandr or used the Monitor Status Indicator Extension I ask because the way the right side is cut off makes me think it may be a hardware problem, this could also be due to driver misconfiguration or you may need to update your drivers. –  l300lvl Feb 20 '12 at 6:03
    
I've never seen the problem on any other configuration than Gnome3. It doesn't occur in Windows, or when I load with the Unity desktop environment. Perhaps it's something to do with my gnome-shell configuration? I wouldn't know how to go about changing that. –  jat255 Feb 20 '12 at 13:41
    
The issue is also not apparent when the LightDM greeter loads. It only shows up after gnome-shell loads, and disappears if I reload gnome-shell with the r command. –  jat255 Feb 20 '12 at 13:42

1 Answer 1

up vote 4 down vote accepted

Nevermind, after looking through and disabling all my startup applications, I isolated the problem to the jupiter applet. Turns out that the "restore resolution" functionality uses xrandr and the script that was calling it failed to change the resolution properly.

I disabled this functionality and now I no longer have the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.