Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running 11.10 on a Dell Inspiron 9400. I ran lshw & it recognizes the BCM4311 802.11b/g WLAN, but I don't see any wireless connections. This is a dual boot machine & the wireless works fine in Windows.

share|improve this question
    
I'm having the same issue - but how did you install the b43 firmware? Ubuntu is completely new to me - so I definitely need stuff like that spelled out, if you'all don't mind! ;-) –  user92683 Sep 25 '12 at 18:03
add comment

2 Answers

Try to install the proprietary Broadcom-STA-Wireless-Driver. Go to the dash, search for "restricted drivers" and install it.

share|improve this answer
    
I have the Broadcom STA wireless driver installed already –  Zeke Feb 19 '12 at 21:27
add comment

I would recommend to open a terminal and install the following:

sudo apt-get install b43-fwcutter firmware-b43-installer firmware-b43legacy-installer

If "An unsupported BCM4311 Low-Power (LP-PHY) device was found." also install

sudo apt-get install firmware-b43-lpphy-installer

Then reboot

Instructions on how to install firmware for Broadcom chips.

http://linuxwireless.org/en/users/Drivers/b43

http://linuxwireless.org/en/users/Drivers/b43?highlight=%28bcm4311%29

share|improve this answer
    
Installing that firmware didn't change anything. I tried sudo apt-get remove bcmwl-kernel-source then I entered sudo apt-get install firmware-b43-installer. Still no luck –  Zeke Feb 20 '12 at 0:50
    
What worked was, I went to the system settings & removed the additional drivers for the broadcom, then I reinstalled the b43 firmware. After I rebooted the wireless showed up. –  Zeke Feb 20 '12 at 1:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.