Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Has anyone had luck installing Ubuntu on this machine. I've tried the default x64 ISO, the amd64+mac ISO and both give me an error about initramfs being unable to find a live filesystem. I've also tried to boot Fedora Linux in live-mode but it too fails to boot.

I read somewhere that I should try boot from the CD while a thumb-drive with the ISO 'burned' on it is also inserted in the machine. That didn't work for me.

I'd appreciate any help.

share|improve this question
    
Are you saying you were unable to boot from the Ubuntu LiveCD? –  Chan-Ho Suh Feb 20 '12 at 1:47
    
I can boot as far as the point where it asks me if I want to do Live Mode or Install. I choose Live Mode and then it comes back with that error. Thanks for the reply. –  Keith Ó Dúlaigh Feb 21 '12 at 15:34

2 Answers 2

I have a late 2011 Macbook Pro 8,1. What worked for me was indeed using a usb pendrive alongside the physical CD. I should also note that I used the 64-bit Mac image (http://cdimage.ubuntu.com/releases/11.10/release/) (edit: I read that you already are aware of it) (I honestly have no clue what the differences are, if it makes any.)

I created a live bootable usb drive using unetbootin from the ISO, then inserted the drive after Ubuntu booted from the CD to its menu. Press a key once that Human logo comes up, then insert the drive when the menu pops up.

After that, select to boot into the live desktop. It will fail to find the image on the disk, but will search the pendrive, and continue to load the desktop. From here, you should be able to install Ubuntu normally, although your woes of getting Ubuntu to work perfectly on the MBP are far from over :) (It is well worth the work, though!)

share|improve this answer

If you are using an older Macbook that is a Power Pc (PPC) you should be using the Ubuntu PPC install image. This worked on my 2007 macbook.

share|improve this answer
    
more info please? –  Stormvirux Feb 23 at 15:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.