Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After trying on some gnome extensions my desktop looks like this:

enter image description here

When I maximize something, it fits well to the whole space, but when the desktop is showed, this white line is showed too. It seems like the wallpaper doesn't want to touch the top bar and gives it some space. It happens with all the wallpapers I tried. Someone could tell me what can I do to fix it? It worked well before trying the extensions.

I've noticed that if I turn off "Have file manager handle the desktop" in Gnome advance settings, the bar disappears but icons on the desktop disappear, too. If I change the Gtk+ theme the bar becomes narrower or changes its colour.

The extensions i've tried were "Music Integration, Overlay Icons, Pidgin Integration, Remove Accesibility and Remove User Name" I've uninstalled them one by one but at the end, the annoying white line remains there, even whit all extensions uninstalled. I've tried also to reset Gnome3 to initial settings doing rm -rf .gnome .gnome2 .gconf .gconfd .metacity but it seems nothing happened at all.

I tried installing a new gnome shell theme, it didn't work either.

share|improve this question
    
Can you tell us what extensions? Also, try disabling them one-by-one to try to isolate the issue. If you figure this out, edit your question or post an answer so others can see what was wrong. –  Tom Brossman Feb 19 '12 at 13:14
    
The extensions i've tried were "Music Integration, Overlay Icons, Pidgin Integration, Remove Accesibility and Remove User Name" I've uninstalled them one by one but at the end, the annoying white line remains there, even whit all extensions uninstalled. I've tried also to reset Gnome3 to initial settings doing rm -rf .gnome .gnome2 .gconf .gconfd .metacity but it seems nothing happened at all. –  user47059 Feb 19 '12 at 14:30
    
I would asusme this was a theme problem. Did you install or enable the user theme extension, or install any additional Gnome Shell themes from anywhere? –  l300lvl Feb 19 '12 at 20:31
    
Searching "theme" in the Software Center, that's what is installed:gnome-accessibility-themes community-themes gnome-themes-extras gnome-icon-theme-full gnome-icon-theme-extras gnome-icon-theme-symbolic ubuntu-artwork gnome-themes-more –  user47059 Feb 20 '12 at 8:48
    
As far as I remember, the default theme uses transparency effects at that specific part of the top bar (probably SVG and CSS properties). Does that happen when you use a different Gnome Shell theme? I don't think there is one available from repositories. –  Alexandre Feb 20 '12 at 21:04

1 Answer 1

up vote 2 down vote accepted

Alexandre's comment put me in the way. It's Unity bar. I solved it just following this steps:

How to remove the menu in the top panel?

Just pasting this on a terminal:

    sudo apt-get remove appmenu-gtk3 appmenu-gtk appmenu-qt
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.