Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to mount a second hard drive into Ubuntu. I've been following this guide and a few others that are essentially the same. Everything's going fine until I try to add a file or folder to the mounted drive - I'm then getting permissions errors.

The guides I've looked at seem to suggest you only need the correct permissions for the folder you're mounting into (/mnt/sdb) in my case. When the HD isn't mounted to the folder I'm able to write to it, however as soon as I mount to the folder I get an access denied error.

I've tried formating the disk as FAT32 and ext3 (FAT32 would be better so I can access the HD in windows) and I'm getting the same error either way. I've also tried various permissions settings on both the directory I'm mounting to and /dev/sdb1 without any success.

Any help would be appreciated.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Are you setting the permissions after you mount the drive?

When you mount a drive into a directory, that directory's permission bits are changed to reflect the permissions of the drive's root directory.

The permissions of the real directory (and any contents of it) are hidden until you unmount it again.

share|improve this answer
    
For some reason I was setting the permissions before mounting the drive. I'm not sure why as that's what the order was in the guide I was following. Thanks for the help! –  splatio Feb 19 '12 at 17:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.