Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu has the built in sinhala unicode support. But it is not the 'wijesekara' keyboard layout. ( http://www.ucsc.cmb.ac.lk/ltrl/services/layout/ ) . How ever 'wijesekara' type pack is available in the web site ( http://www.siyabas.lk/sinhala_how_to_install.html ) . But the problem is it is only available for ubuntu 9.04. I tried to install this package in ubuntu 11.10. But failed :-(. What should I do?

share|improve this question
    
Having same problem setting up Sinhala, Tamil, English keyboard for friend. I'll be watching this thread. –  C.S.Cameron Feb 19 '12 at 15:17
    
The method on this page almost seems to work sinhala.sourceforge.net –  C.S.Cameron Feb 19 '12 at 17:00
    
yes... it installs sinhala... but not the usual keyboard layout!! –  chathurawidanage Feb 21 '12 at 4:55
    
iBus is the solution - help.ubuntu.com/community/ibus –  Maduka Jayalath Jul 13 at 15:57

2 Answers 2

This link will provide the source for the solution. The original Debian 6 source has been revised for compatibility with Ubuntu.

• Open the terminal and run:

sudo apt-get install ttf-sinhala-lkmug ibus im-switch ibus-m17n m17n-db m17n-contrib language-pack-si-base
rm -f ~/.xinput.d/* ; im-switch -z all_ALL -s ibus  

• Logout and login again. Environment variables need to be set/updated (NO NEED TO REBOOT).

• Select your keyboard layouts by opening the terminal and running:

ibus-setup  
share|improve this answer

I also have this problem. Sinhala-lk-lug font can be installed using the following command (as root):

By installing using the above command and making suitable setting in Language Support {ibus} and Keyboard Input Methods {add required languages} Sinhala unicode could be used without any trouble in 12.04 as well as previous versions of Ubuntu. But for some time now, although the language selector shows up there it is not possible to type using Sinhala. This might be caused due to a regular software update.

Note: When using the above-mentioned long command to install Sinhala Unicode, the Terminal gives a message that instead of "ttf", "fonts" will be selected.

http://mtechzone.blogspot.com/2011/11/unicode-sinhala-fix-in-linux-ubuntu.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.