Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I downloaded Wireshark from the Ubuntu 11.10 software center and when I start it and want to select default interface for capture in the list of interfaces are blank. I can't select default interface. Please help me.

share|improve this question

marked as duplicate by Jorge Castro, Sneetsher, psusi, Danatela, Warren Hill Jun 3 at 11:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Try running wireshark by gksudo wireshark, you will need sudo permissions to capture packets on your network interface. –  nitstorm Feb 19 '12 at 8:11
    
@nitstorm thanks. –  geoh Feb 19 '12 at 8:23
2  
The answers here are more dangerous than the standard "sudo dpkg-reconfigure wireshark-common" approach, which is documented in this question: How do I run WireShark, with root-privileges? - Ask Ubuntu. This question is essentially a duplicate of that one. –  nealmcb Jan 15 '13 at 23:50

2 Answers 2

up vote 2 down vote accepted

Run wireshark with sudo priveleges - gksudo wireshark. You will need super-user permission to capture packets from your network interface.

share|improve this answer
    
thank you very much –  geoh Feb 19 '12 at 8:36
    
No problem :) Most welcome :) –  nitstorm Feb 19 '12 at 8:41
1  
This is unnecessarily dangerous and problematic, because there are far more exploitable bugs when running the full gui as root, and configuration issues can crop up when a gui program runs as root. See the dpkg-reconfigure solution at How do I run WireShark, with root-privileges? - Ask Ubuntu for a much better option –  nealmcb Jan 16 '13 at 0:01
1  
I just saw that and have also voted to close this question off as a duplicate of that one. Thanks for pointing this out @nealmcb :) –  nitstorm Jan 16 '13 at 18:53

This command string worked in my case. I don't run anything as root if I don't have to.

sudo chgrp your username /usr/bin/dumpcap
sudo chmod 750 /usr/bin/dumpcap
sudo setcap cap_net_raw,cap_net_admin+eip /usr/bin/dumpcap
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.