Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was toying around with different kernels on my Macbook Pro, and during the process my Xorg.conf got wiped out. After I rebooted with a more recent kernel, and re-installed the Nvidia driver, I found my screen brightness will change, seemingly randomly.

It normally seems to happen after I resume from suspend, or when I open the System->Administration->NVIDIAa X Server Settings app while plugged in. The brightness will start super bright if I'm in a dim room, or super dim if I'm in a bright room. This normally wouldn't be a problem, but the brightness is usually too extreme, making the screen painful to look at in either scenerio.

Even more frustrating, if I manually set a brightness, it'll reset it a few minutes later. I unchecked the "auto-dimming" option in System->Preferences->Power Management, but it still occurs.

How do I disable this feature?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

That's a general gnome setting. Assuming you got a recent version of ubuntu, just install dconf-editor and navigate to org.gnome.settings-daemon.plugins.power. The idle-dim-time is what you want to change. The value is given in seconds.

share|improve this answer
    
Thank you so much Andy! –  etsr Dec 10 '12 at 5:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.