Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Basically the title explains it. I was editing the xorg.conf file to make use of a multitouch driver and everything was fine, but when i added a certain option

Option "SwipeRightButton" "Mod4+Left" "10"

I could only boot to a purple screen. When i tried to go into recovery i could not navigate any of the menus.

I'm currently in the process of a fresh install.

share|improve this question
don't fresh install, just restore the xorg.conf file. – zookalicious Feb 18 '12 at 22:41
I already did, and i'm back up and running but for future reference, how do i restore the xorg.conf file? – Wilfred Feb 19 '12 at 20:38
usually there should be a xorg.conf.backup in the same folder as your xorg.conf and all you should have to do is boot into recovery mode and then replace the broken file with the backup, sorry I'm in a rush right now, I'll elaborate on that later. – zookalicious Feb 19 '12 at 23:04
yeah i can just do "mv xorg.conf xorg.conf.backup" in terminal to make that backup right? but I was also having the issue where when I booted into recovery I could not navigate through the menu. Even the up and down arrows were not working, I couldn't even press enter. – Wilfred Feb 20 '12 at 14:52
up vote 0 down vote accepted

The xorg.conf man page documents the correct format, and the generic options. Driver-specific options are usually (but not always) covered in the man page for the driver. In most cases, you can simply rename xorg.conf to another name to get X to start with a safe set of default options - xorg.conf is only needed when you want to change a setting from the default value to customize your setup.

share|improve this answer
Thanks for clarifying! I think my main issue was that when I booted into recovery I could not navigate the menus, do you know anything about that? – Wilfred Feb 20 '12 at 20:03
Sorry, I do not. – alanc Feb 21 '12 at 16:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.