Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed grub-customizer to edit the boot-screen. It works so far (i. e. for timeout), but changes concerning the background image (and maybe font styles, too) aren't applied. I placed the image in /boot. How to improve that?

This is what /etc/default/grub says:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="Ubuntu, mit Linux 3.0.0-16-generic"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="3"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap"
GRUB_CMDLINE_LINUX="splash vga=795 quiet"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="1280x1024"

GRUB_GFXPAYLOAD_LINUX="1280x1024-24"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_SAVEDEFAULT="false"
export GRUB_MENU_PICTURE="/usr/share/backgrounds/warty-final-ubuntu.png"
export GRUB_COLOR_NORMAL="dark-gray/black"
export GRUB_COLOR_HIGHLIGHT="white/black"
share|improve this question

2 Answers 2

up vote 1 down vote accepted

I found out that I had to crop/resize the image according to the screen-resolution. Similar problem found here.

share|improve this answer
  1. Find out you screen resolution (for Xubuntu, System Settings > Display) example 1600x900
  2. Resize your pic to the same as screen resolution size (which in my case 1600x900)
  3. Just to save some space, also reformat the pic in .png format.
  4. Under the grub customizer menu, select the check box for custom size and enter your screen resolution size (same size as pic) example 1600x900
  5. Add your picture and save.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.