Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a LiveUSB of Ubuntu 10.10 to see if this bug I reported in Aug 2009 has been fixed. Sadly, it seems like it has not.

This is what I did to test: I booted with a Ubuntu 10.10 LiveUSB, I updated everything using Synaptic: including pulse and other sound related packages, everything except the kernel. After that I opened Sound Preferences,made sure sound input was not muted, moved the input volume all the way, opened Sound Record and tried to to record some sound. I could hear only static. Basically I cannot get any sound from the microphone that is on the chasis of this lenovo x300 laptop.

My theory is that pulse or alsa are only able to get sound input if I connect an external mic to the jack. I tried using an external mic a few months ago and it worked. But I don't want to use external mics, I want to use the mic on the laptop itself.

Any suggestion on how to solve this problem?

share|improve this question

closed as off topic by Bruno Pereira, Marco Ceppi Feb 2 '12 at 18:16

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You can update the sound drivers from the live cd (you'll then need to prevent pulse from autospawning, kill pulse, reload the sound drivers, then re-enable pulse's autospawn) to a daily build and see whether that is the culprit. Please make sure to use alsa-project.org/alsa-info.sh after loading the new sound drivers. –  Daniel T Chen Nov 23 '10 at 22:13
    
This question has not information added in it for a very long time and probably describes a bug in old package versions. I have flagged it to a moderator so it can be closed. If you think that this is still a valid question and that you are still suffering for this issue you can always flag it so that it can be re-opened. –  Bruno Pereira Feb 2 '12 at 17:15

1 Answer 1

I have also faced the same problem with Ubuntu 10.10 and because of this I was unable to use skype. However, after fresh install of Ubuntu 11.04, mic is working fine. I don't know how it is working now. But it is worth to try.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.